Reconfiguring a new temperature sensor

Can we please go through the steps to replace and reconfigure the controller for a new “Beer” temperature sensor. It’s not working for me.

  1. Stop Script
  2. Go to maintenance panel
  3. Go to devices
  4. Refresh the devices list
  5. Unassign the “bad” device and place its function as “none”
  6. Press Accept
  7. Refresh the devices list - at this point to old device is still present in the list showing unassigned and none.
  8. Find the new temperature sensor in the Devices Detected list
  9. Choose a new slot for it and select it’s assignments
    10 Press Accept

I’m trying to do this from a remote VNC connection, but it is not working for me or I am not doing it properly.

Can someone please help?


Houston, Texas Brewer
Currently in Bahia Blanca, Argentina

Why step 1? The web interface needs the script to run to talk to the hardware. Without the script running, you wouldn’t be able to do step 4.

2-4 correct.
5. Set function to none and click apply. Do not change the slot when doing this.
6-10. Make sure you are setting it to beer device, beer 1.

Thanks. Thought the Script had to be running.

Following your advice I was able to clear the old device from slot 1. I detected the new temperature sensor, put it in slot 1 and configured it for beer temp.

Unfortunately it is reading “null”.

I assume I am still doing something wrong.


If you tick the box ‘read values’, do you get a valid temperature reading in the device manager?

No, it says “nill”…“null”. I assume the probe is bad…or the epoxy I let flow down around the wires into the RJ-12 connector has messed it up.

I ordered new spare temperature sensors last week. I should have them by the time I get home.

I had one of my probes reading ‘null’ as well and ran this command from the post in 2015 from Elco, the probe started reading again and I was able to assign…

ElcoBrewPi FounderSep '15
Uninstall should work by setting the function to none and clicking apply. I don’t know how it could get in a state where this is not working.

If you want to start fresh, sending ‘E’ over serial will reset all settings.
On the Pi:

sudo echo -ne ‘E\n’ > /dev/ttyACM0

I’m new here though and have little to zero knowledge about any of this… :smiley:


Also… although one of my probes showed ‘null’ under: Maintenance Panel–>Device Configuration
I noticed that if I set the mode to test (Maintenance Panel—>Advanced–>Mode–>Test Mode) the raspberry pi spark v2 itself (meaning looking at the panel on the spark v2) would display temperature on all four probes that I had plugged in telling me that there was nothing wrong with the probe itself… Again… I’m a noob so these are just my observations… :smiley:

1 Like

Thanks. I will give that a try before I replace the temperature sensor.

Thanks, that’s good info. I can use that to see if there is something wrong with the temp sensor init/update cycle.

I arrived back home this morning. I found the communication was “hung-up” (Script not updating) between the RPI and BPi, so I rebooted both. After the reboot, the temperature sensor previously reporting “null” was showing a correct temperature.