Software Install Guide

oh, and with new screen on brewpi, still can’t connect to any serial ports

Are you powering the raspberry pi from a docking station? Do you mean USB hub?
It could be that the raspberry pi and brewpi are not getting enough power.

Can you try plugging the brewpi into a PC and see if it shows up in device manager?

I am starting to wonder whether the latest version of Rasbpian has drivers for the Photon.
I will try a full re-install this weekend to see what’s up.

ok, haven’t other people already done this install w/ the photon? I can’t be the first, right?


good news! I upgraded my RaspberryPi power supply to a 5V/2A, and put in a “better” USB-USB Mini cable between my Raspberry Pi and Brew Spark, now the script loads!

There should be a sticky post on the forums which says, “No matter what your issue and how unrelated you think it is to power supply or quality of connection, start by upgrading all of your cabling and see if your problem persists”

I had an issue where I thought my Pi’s MicroSD was running out of space and causing OS issues, but this problem turned out to be a cabling issue. It seems almost any random problem can have cabling as the root cause.

Great advice but how do you know what stuff is “good”. Certain brands? Do they have certain specs to look for? Just getting into this…

So I am trying to set up my Raspberry Pi and I have done all updates up to the git clone ~/brewpi-tools. Once I enter this in the next line is:
Cloning into ‘/home/pi/brewpi-tools’…
fatal: unable to access ‘’ Could not resolve hot:

I am not sure if I’m doing something wrong but I need help.

@joejr This probably is a dumb question but you are still connected to the internet correct?

@bryancm1 I was operating on the Debian Jessie version and it was giving that issue. I reinstalled with Debian Wheezy and it works great now. Not sure why it was giving that issue. All I’m waiting on now is for my brew pi to come in the mail. Thank you for asking and helping.

As a BrewPi noob I took notes on getting the software installed. Here they are in case they’re useful to anyone else:

Next week I’ll be converting a fridge so will probably be asking some questions :smile:

Thanks for taking notes!
I am going to move the documentation to, so it will be easier for others to contribute updates.

I’m finally getting around to setting up my BrewPI Spark V2. Was it supposed to come with an SD card? I just took it out of the box and didn’t find one. Or is it just preloaded with Plug 'N Play goodness? The unit seems to recognize my temperature probes and powerswitch tails, but I can’t seem to do anything else other than stare at the hardware test mode on its display.

Hi Eric,

I think there might be some confusion. Inside the BrewPi Spark is a Particle Photon, not a Raspberry Pi.
The Raspberry Pi needs and SD card and you need to buy one separately. Then you can follow this software install guide to install software (on the Pi) and afterwards connect the BrewPi Spark to the Raspberry Pi via USB for data logging and configuration.

The photon runs the control, the Raspberry Pi runs the Web interface and data logging.

We will release an update to connect the Raspberry Pi and Photon over WiFi later, but this is not available yet.
The BrewPi Spark does have an SD card slot, but it is not used by the firmware. We can perhaps start using it later to buffer data when the connection to the web server is dropped.

The BrewPi Spark is preloaded with firmware, which is in test mode until you configure it differently via the Pi.


Hi !
I have been trying to get my brewpi up and running the past 2 days.
Everything goes as plan up to the part where I am going to run the " sudo ~/brewpi-tools/ "
Then I get s ton of “fail to fetch” errors. Have tried different PI and SD cards. Same problem appears.
All the apt-get update, upgrade have now erros. Need some help before I go crazy.
Thanks OJ

That sounds like a problem with your internet connection on the pi.

If you run:

sudo ping

What does that give you?

Don’t think it eny problem with internet

pi@raspberrypi:~ $ sudo ping
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=54 time=130 ms
64 bytes from ( icmp_seq=2 ttl=54 time=137 ms
64 bytes from ( icmp_seq=3 ttl=54 time=129 ms
64 bytes from ( icmp_seq=4 ttl=54 time=132 ms
64 bytes from ( icmp_seq=5 ttl=54 time=129 ms
64 bytes from ( icmp_seq=6 ttl=54 time=128 ms

that looks alright indeed. If you try again now, does the problem still occur?

Yes still the same

Checking whether this script is up to date…

/home/pi/brewpi-tools is up-to-date.

***** Installing/updating required packages… *****

Reading package lists…
Building dependency tree…
Reading state information…
build-essential is already the newest version.
git-core is already the newest version.
python-pip is already the newest version.
The following extra packages will be installed:
apache2-bin apache2-data apache2-utils libapr1 libaprutil1
libaprutil1-dbd-sqlite3 libaprutil1-ldap liblua5.1-0 libonig2 libpython-dev
libpython2.7-dev libqdbm14 lsof php5-json php5-readline python2.7-dev
Suggested packages:
apache2-doc apache2-suexec-pristine apache2-suexec-custom php-pear
php5-user-cache openssl-blacklist
The following NEW packages will be installed:
apache2 apache2-bin apache2-data apache2-utils libapache2-mod-php5 libapr1
libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap liblua5.1-0 libonig2
libpython-dev libpython2.7-dev libqdbm14 lsof pastebinit php5 php5-cgi
php5-cli php5-common php5-json php5-readline python-dev python2.7-dev
0 upgraded, 25 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,455 kB/26.9 MB of archives.
After this operation, 65.4 MB of additional disk space will be used.
Err jessie/main apache2-bin armhf 2.4.10-10+deb8u4
404 Not Found [IP: 80]
Err jessie/main apache2-utils armhf 2.4.10-10+deb8u4
404 Not Found [IP: 80]
Err jessie/main apache2-data all 2.4.10-10+deb8u4
404 Not Found [IP: 80]
Err jessie/main apache2 armhf 2.4.10-10+deb8u4
404 Not Found [IP: 80]
E: Failed to fetch 404 Not Found [IP: 80]

E: Failed to fetch 404 Not Found [IP: 80]

Can you try running:

sudo apt-get update
sudo apt-get upgrade