BrewBlox install issue

If I do a new install, everything seems to go OK until I get to the bootloader flash, where I get this error message.

pi@raspberrypi:~/brewblox $ brewblox-ctl bootloader
Please press ENTER when your Spark is connected over USB
The following shell commands will be used:

     docker-compose down
     docker pull brewblox/firmware-flasher:rpi-edge
     docker run -it --rm --privileged brewblox/firmware-flasher:rpi-edge flash-bootloader

Press ENTER to continue, Ctrl+C to cancel

Running command:
docker-compose down

Removing network brewblox_default
WARNING: Network brewblox_default not found.

Running command:
docker pull brewblox/firmware-flasher:rpi-edge

rpi-edge: Pulling from brewblox/firmware-flasher
Digest: sha256:1f72340c62c50c1792396fad34f1dbbb13c3e804bce6b8ce4bf1dd66440df0d5
Status: Image is up to date for brewblox/firmware-flasher:rpi-edge

Running command:
docker run -it --rm --privileged brewblox/firmware-flasher:rpi-edge flash-bootloader

Triggering listening mode
Flashing P1 bootloader…
! PROTIP: Hold the SETUP button on your device until it blinks blue!
? Press ENTER when your device is blinking BLUE

Error writing firmware: Timed out waiting for initial response from device
Traceback (most recent call last):
File “/usr/local/bin/brewblox-ctl”, line 11, in
File “/usr/local/lib/python3.5/dist-packages/brewblox_ctl/”, line 81, in main
File “/usr/local/lib/python3.5/dist-packages/click/”, line 764, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python3.5/dist-packages/click/”, line 717, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python3.5/dist-packages/click/”, line 1137, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python3.5/dist-packages/click/”, line 956, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python3.5/dist-packages/click/”, line 555, in invoke
return callback(*args, **kwargs)
File “/usr/local/lib/python3.5/dist-packages/brewblox_ctl/”, line 175, in bootloader
File “/usr/local/lib/python3.5/dist-packages/brewblox_ctl/”, line 130, in run_all
return [run(cmd) for cmd in shell_cmds]
File “/usr/local/lib/python3.5/dist-packages/brewblox_ctl/”, line 130, in
return [run(cmd) for cmd in shell_cmds]
File “/usr/local/lib/python3.5/dist-packages/brewblox_ctl/”, line 124, in run
return check_call(shell_cmd, shell=True, stderr=STDOUT)
File “/usr/lib/python3.5/”, line 271, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘docker run -it --rm --privileged brewblox/firmware-flasher:rpi-edge flash-bootloader’ returned non-zero exit status 1

Is you brewpi now unresponsive?

It’s a brick with a pretty display at this point. It’s unresponsive in the web interface and gives a lot of error messages. I don’t have high hopes for the IPA that was fermenting as it got so hot, but luckily I have a second fermentation freezer controlled by a BrewPi Legacy Remix setup that is totally reliable and moved it over to that.

That’s really not good. I’m afraid you’ll have to mail us your Spark so we can reset it.

Meanwhile, I did figure out the issue with your first link, so was able to read that (two characters too many).

The log is showing multiple reboots due to the reset pin. Was that triggered by you?

During the bootloader flash, did you press any buttons on the Spark itself?

I’ll go and try to reproduce the error with one of our Sparks. If both you and uk_brewer have the same problem, then it’s much less likely to be a hardware issue. I’ll go test one of the Sparks in the office, to try and reproduce the problem.

He said it is a brick with a pretty display, so please clarify whether it is bricked. If it is showing something on the screen it is clearly working.

No, I didn’t press any buttons during the bootloader flash. I was using SSH from my desktop computer and the Spark is two rooms away from that one. The display is still working but I can’t get the Spark to do anything from the web interface as I try to set up a fermentation freezer from the wizard and it gets to the part just before it sets it up and stalls, then I get error messages. If I try to reinstall BrewBlox, I get to the bootloader flash step and that fails to flash every time.

It’s something we’ll look at, but if you’re reinstalling BrewBlox, you don’t need to flash the bootloader.

If you run lsusb, what does it show?

I actually recommend setting up WiFi and skipping usb. If the spark had WiFi it can update the bootloader from the cloud itself.

Bus 001 Device 007: ID 2b04:c008
Bus 001 Device 005: ID 0424:7800 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

After starting BrewBlox again, when I tried to set up the Ferment Fridge through the wizard I was getting error messages- Failed to create Ferment Fridge Setting: 500: CommandException(CREATE_OBJECT failed with code INSUFFICIENT_PERSISTENT_STORAGE). The second error message was the same one but it started with Failed to Execute Actions. I also received a bad gateway error message. I set up the WiFi and then deleted all of the blocks and tried again, and it works again.

1 Like