Brewpi froze my beer!


#21

Thanks for confirming this was on 0.4.3. This bug is fixed in 0.4.4.
Your settings are saved and restored during the update process.


#22

You are welcome. Thanks it is updated and all my settings were saved. I am having another issue also that i hope you can help me with. Possibly it is on another thread but I can't find it.

Basically, when I try to run a beer profile nothing happens and I get a socket error (32): broken pipe

Any help would be greatly appreciated.


#23

Also, tried this on both Safari and Firefox and I am adding a picture of my set-up as I have read that this might matter.


#24

It might be a too simple suggestion, but can you try restarting the pi with 'sudo reboot'?


#25

Ok. Just tried sudo reboot and did not fix the problem. Also, bought a new microUSB adapter to connect rPi and BrewPi. Still getting the socket error, tho.


#26

Can you try this:

sudo python /home/brewpi/brewpi.py --kill
sudo rm /home/brewpi/BEERSOCKET

The wait for the script to restart.


#27

Dang. Still did not fix the problem. Here is a picture of the socket error read out and the contents of
sudo ls /home/brewpi/


#28

The profile being ' ' made me think of another possible issue. Maybe your settings files got corrupted or something.

Can you run this:

cd /home/brewpi
git diff
git reset
rm ./settings/config.cfg

cd /var/www/html
git diff
git reset
rm ./config_user.php

If the output of git diff is not empty, let me know what it said.

If this doesn't help, please run the install script again for a clean install.


#29

Ok. I did this but now I have a "cannot receive script" problem....Here are the outputs for both git diff commands.


#30

So, I can't tell if this fixed the problem because I have a "cannot receive script" error. Any ideas?


#31

can we talk on Skype? this seems to be inefficient. I'd like to connect remotely and help you fix it. I'll send you my skype name in PM.