Cannot save temp sensors

Hi Elco. I’ve upgraded my brewpi to the latest version (0.5.10) but I can no longer save the temp sensors. I can set up and save the heater and cooler but every time I try and save the beer temp and chamber temp they revert to function: None. What info do I need to send you to be able to get some help? I have the raspberry pi connected via ethernet and the Brewpi connected to it with a USB cable.

I recommend upgrading to BrewBlox instead. BrewPi will not be developed further and we’ll continue to improve BrewBlox.

Ok, thanks for the reply can you direct me to the procedure? It’s just a fermentation chamber that I will be running.

You can find the install guide at brewblox.netlify.com

Hi Bob. I’ve installed BrewBlox and everything seemed to go ok but i’m having issues. Firstly the Spark’s screen is white and secondly when i open the web portal i get the message: Failed to discover objects on spark-one: Bad Gateway. The only part of the install that i did not follow was ‘Enable SSH and Wifi’. I enabled SSH using raspi-config and i am connecting using an ethernet cable. I can connect fine via SSH.

Did you configure Wifi on the Spark? Particle recently released an update to the bootloader, which will be automatically downloaded if the Spark has Wifi.

Expected behavior after Wifi is configured is that the LED will blink/shine purple for a minute, and then reboot.

Yes, i followed that bit. The router’s wifi doesn’t reach into the garage well so i have it connected to a powerline network vie ethernet.

This is about the Spark, not the Pi.

If Wifi is not available, you can manually update the bootloader by running brewblox-ctl bootloader --force.

Thanks Bob. That solved that issue. I’ve put it into Fridge constant temp mode and set at 4C and awaiting it to start cooling, it had been heating because the wizard’s default values are 20C so i assume that there will be a delay before the cooling is triggered? It has been about 5 mins so far…

There indeed is a lockout when switching between heating and cooling. The default value is 45 minutes, due to the fridge compressor requiring a long minimum off time.

If you want to skip that lockout right now:

  • Go to the Spark service page
  • Look for the Mutex block
  • Click the cogwheel button to go to the settings display
  • At the bottom, edit the lockout period to 1 minute
  • Wait for the fridge to turn on, and change the lockout period back to 45 minutes

Thank you all sorted. I’m actually using the fermentation fridge to control the temp of the Christmas ham in a cider cure. Luckily the weather has been cool enough to leave it outside whilst i have been figuring this out so thanks again for getting it sorted for me. Christmas lunch saved!