Edge release 2019/12/17

Could you please run brewblox-ctl log?

Ok ran that

It looks like you also edited the docker-compose.shared.yml file. That is where shared system services are configured - you never have to edit that.

You can restore it by running the following command in the brewblox dir:

cp -f brewblox_ctl_lib/config_files/armhf/docker-compose.shared.yml ./

EDIT: to prevent weirdness in your next update, run:

dotenv --quote never set BREWBLOX_CFG_VERSION 0.3.0

Did all of that, still the same
Connecting https://localhost:443/history/ping, attempt 59/60
Connecting https://localhost:443/history/ping, attempt 60/60
Retry attempts exhausted
Command ‘/usr/bin/python3 -m brewblox_ctl http wait https://localhost:443/history/ping’ returned non-zero exit status 1
Command ‘/usr/bin/python3 -m brewblox_ctl migrate --prune’ returned non-zero exit status 1

Thinking maybe time to format and start again, but I am guessing if I do that, will have no way of retreiving herms build?

So far it looks mostly like there’s a hiccup in your settings. That can be fixed without resorting to drastic measures such as reinstalling.
When looking at your earlier log, I think right now the update is breaking your configuration, because it thinks it still has to migrate your config files.

Could you please run brewblox-ctl log again, along with:

cat .env | nc termbin.com 9999


Here they are

env file looks ok, but the update reset your shared compose file again.

If you run

cp -f brewblox_ctl_lib/config_files/armhf/docker-compose.shared.yml ./
docker-compose pull
docker-compose up -d
docker-compose ps

You should see the history service in the output generated by docker-compose ps

If that works, you can continue using your stuff (the update being already done)

Many thanks - that worked

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.