Legacy using Docker and legacy install issues

He did that, but I’m not sure he also did it in the www dir.
Try a ‘git reset --hard’ in both directories to undo any changes you made.

You deleted the default settings

Okay so today I tried ‘git reset --hard’ on both dirs, and then reloaded the webpage and it worked just fine - everything seemed to be normal, logs were fine and devices working properly. I was happy. Then I started a new brew - set a new name and reloaded the page and boom, script not running again. Logs now say - can’t find log file.
Device configuration gives me a missing token in json file error.
I did try removing browser cookies and reloading to check if that was showing me an older cached result but no it does not run again, even on another browser. I had 2 minutes of up time thats it.

:frowning: :frowning: :frowning:

Tried reloading again, I created the two log files manually, now I get the following errors in logs:

Traceback (most recent call last):
File "/home/brewpi/brewpi.py", line 183, in 
dontRunFilePath = os.path.join(config['wwwPath'], 'do_not_run_brewpi')
File "/usr/local/lib/python2.7/dist-packages/configobj.py", line 554, in __getitem__
val = dict.__getitem__(self, key)
KeyError: 'wwwPath'

I tried git reset --hard again and reloaded the browser again and that seemed to work. It was working but I noticed that the UI does not reflect any of the name changes to profiles. I then tried to stop the script and restart it just to see if that was the issue and yes it was. Now the script does not run again.

Going by these instabilities, we are considering getting the Spark 3.
Looking at the setup, what kind of pluggable terminals do we need to connect the relays cabling to the Spark?
I don’t see them at the BrewPi store. Could you give us some technical info about them so we can buy them in India where we are located?
If that’s sorted then I think we should be able to buy everything else from the BrewPi store.


They are included with the Spark.

Oh great! We will place an order.