No graph after changing to a new brew/profile

Hi everyone

I just finished building my brewpi. Everything seems to be working fine and I got the website up and running.

The problem is that when I change the brew or profile from the original “your first brewpi run” to something else the nice graph just doesn’t show anymore. It’s just a white space.

I can see the current temperatue of beer and fridge up in the left corner on the “LCD” though.

Does anybody know how to fix this?

Sorry helgibelgi, not a fix, same issue here. Everything works flawlessly under the “My First BrewPi Run” but changing the brew causes that same issue for me. Big white blank space, no graph. Refresh doesn’t bring anything in either.

Only other issue (may be related or not) is that I cannot start a script from the web interface, only through the pi. I can stop one via web but not start it. (I have to use sudo -u brewpi python /home/brewpi/

any ideas?

Hey guys. This happens when you start a new brew. You have to leave it for a bit before logging starts and then refresh the web page.

Hey Dan,

Thanks for the tip - just started a new brew, it is blank but I’ll give it a bit and see if the chart shows? Seems odd but I’m game.

Will update shortly.
// brian

(forum is making me edit an old post rather than reply)

Thanks Elco, below is what I got when refreshing in console. I do have to start the script manually by typing (sudo -u brewpi python /home/brewpi/

When I tried running “/home/brewpi/tools/” I get a directory error.

What should I try from here? Much appreciated.

Ok, did a little digging and found : sudo /home/brewpi/utils/
Ran that, said it fixed permissions for pi
Restarted script manually.
Created a new brew and ive got data!

It’s been about 24 hours here and still no graph. Looks exactly like the screenshot from anticlimaddox.

I tried reprogramming the arduino through the web interface. Did not fix it.

I guess I’ll have to try setting up the brewpi software again. But it’s a hassle for me to connect my brewpi to a tv and keyboard and mouse, so I’m hoping someone comes along and gives an easy solution before I do it.

This is not an issue with the Arduino.
In chrome, can you hiet F12 and go to the console tab and refresh (F5)?

It there is a JavaScript error, it will show up there.

Did you manually start the BrewPi script or did it start automatically?
If you started it manually, it probably did not run under the brewpi user and the web server might not have the right permissions to access the files.
You can fix that by running /home/brewpi/tools/

I had this same problem and the graph area has been blank for over 24 hours. I connected to the Raspberry Pi and did some snooping around. If I start the brewpi script manually, among the console info displayed while starting it mentions logging for ‘My First BrewPi Run’. This is not the name I set from the web page so I’m wondering if the data point logging is being done for this name and not the new name. Grep’ing through the files, I found the string in the /home/brewpi/settings.defaults.cfg file. So I copied the config.cfg file to another name, edited the new cfg file and adding the “beerName =” line. I restart the script manually specifying the new config file using the --config option in the command line. When I viewed the web page, the graph was displayed with data points. I don’t know if it’s what I did with the new config file or simply just restarting the script manually (disconnecting the Remote Desktop Connection will kill anything currently running in FG unless I run the command in BG using the ‘&’ at the end of the command, not sure if this puts a wrench into cron).

So Elco, your code didn’t work exactly but put me on the right track,

I did a little digging and found : sudo /home/brewpi/utils/
instead of : /home/brewpi/tools/

Ran that, said it fixed permissions for pi
Restarted script manually with : sudo -u brewpi python /home/brewpi/
Thus running “My First Brewpi”

From the webui I created a new brew and got a prompt to wait a few minutes and then reload (instead of a blank screen) Reloaded after a bit and I have new data!

Hi all

Just got around to finally fixing my brewpi this week and wanted to give an update to those who might be having similar problems.

For the initial problem of the graph not showing the solution from anticlimaddox works: sudo /home/brewpi/utils/

I did run into other problems because I did not set up a static ip address initially. So after fixing the no-graph problem I couldn’t even find the website to see if it actually had been fixed. Apparently the router can assign the pi a new address every once in a while. Not cool. For those having problems with setting up a static ip address the best tutorial I found was this:

Now everything is wonderful again. Thanks to everyone who replied and tried to help :smile: