Software Install Guide

For a single BrewPi Spark connected to a Raspberry Pi is just 3 commands to do the install of the BrewPi Software.

sudo apt-get install git
git clone ~/brewpi-tools
sudo ~/brewpi-tools/

The update script is only for down the road when they release new version of software or core software companants need to be updated

sudo ~/brewpi-tools/

1 Like

I have followed the Software Install Guide faithfully but from the BrewPi Browser I cant get the script to run.

In running I am asked …

*** Updating BrewPi web interface repository ***
The path ‘/var/www’ does not seem to be a valid git repository
What path did you install the BrewPi web interface scripts to?

Can anyone advise what the answer to this question is ?

If you are using Wheezy take the default. If you are running Jessie, it should be /var/www/html.

New RaspPi users may have an issue remotely (outside of LAN) accessing a wifi ONLY BrewPi Server (i.e. not ethernet cable connected). This is because external port forwarding from many routers will have a difficult time forwarding correctly (from external …no issue if within LAN or using VPN).

seems that eternal port forwarding (without ethernet, eth0, connected, REQUIRES the implementation of the static IP to be hard coded (i.e. not via GUI):

static ip_address=192.168.1.XX

ssh into your RaspPi:

sudo ssh pi@YOUR.RASP.Pi.IP
sudo cd /etc/
sudo nano dhcpcd.conf

edit the /etc/dhcpcd.conf file and add the the following:

static ip_address=192.168.1.XX

where 192.168.1.XX is your RaspPi 's static IP for the wlan0 (wifi adapter). I would recommend also adding an IP reservation to your router OR place the RaspPi’s wifi IP outside the dhcp range on your router.

The GUI assignment of defining an IP does NOT make it static…and in turn will not allow your router to port forward to the wlan adapter

Is it possible to use the Sainsmart 2 channel relay for both heating and cooling? I had it hooked up (incorrectly apparently) and anytime 1 relay would go meet the critera to turn on it would turn both on… I think becase the VCC is shared? Attached is a picture… perhaps you can tell me where to place the remaining 2 wires (port 1 +/-)…thanks in advance.

I recommend using SSRs, because they switch on a zero crossing of the AC signal and will cause less noise and interference because of it.

It will also be easier to connect, because this board needs a separate supply for GND and VCC.

This is how another user solved it:

Please note that the BrewPi Spark switches the negative pin, not the positive pin.

Everything I am running is DC (12V DC pump and heat pad).

In that case, SSRs would not work. The rest still applies.

after adding to /etc/network/interfaces file my internet doesn’t work anymore. The browser says “This site can’t be reached”

This is my fourth attempt at installing and my fourth time installing Noobs to get the Brewpi running. My patience is about up. Had I known the installation would occupy so much of my time I wouldn’t have purchased one. I feel a little cheated as at no point were there warnings that this is a device that requires moderate understanding in computers. What is the point of buying the pre-fab item if it requires the same degree of setup as making your own?

Sorry if I am coming off as ornery but I have put in close to 15 hours on this and I keep finding myself at the beginning again! What am I doing wrong if I am following your directions down to the word?

Can you connect a keyboard and monitor/tv connected to the Pi?
That would make it a lot easier to fix the Internet connection instead of starting again.

I suggest you skip the static IP settings and install avahi-daemon:
sudo apt-get install avahi-daemon

This is the same as the bonjour service by apple. If you already have iTunes installed on your PC, you can now access the raspberry pi by visiting: http://raspberrypi.local

I’ll also reply to your e-mail with my Skype details so you can ask for support directly, because you put in so much time already.

Thank you Elco, I appreciate the help!

thanks to all

Very great job

Hi. I’m still having a ton of trouble just getting the Brewpi set up. I’ve followed the install and tried to run the updater, but am getting the following error at the end of the process “Could not find compatible device in available serial ports”. The Brewpi Spark V2 is attached to the Raspi and the display is on. I am able to go through the touch screen callibration. I have some probes plugged in and the screen shows a room temperature reading. I just cannot seem to get the Brewpi to communicate with the Raspi. You’ll have to forgive my limited understanding of code, but I’m unsure of how to look into the serial port mapping to try and direct this the proper way.

Any help is greatly appreciated. Thanks in advance.

You can see which ports the system sees and which BrewPi thinks are compatible if you run: python

My guess is that you should try another USB cable. The USB connector on the Photon is picky. The pi probably doesn’t see the spark at all.

I switched cables and it now works after trying a third, but shortly after it showed the script as “running” it stoped again. Is there any way to fix this? TheUSB connection is so spotty that this is basically un-useable.

Maybe the USB connector on the Photon is damaged. They are fragile and a yank on the cable can cause it to become too loose.

If the internal part of the USB connector is damaged, only replacing the entire Photon is a good fix. If the outer shell got too loose to hold the cable in place properly, slightly bending it back py pushing down on the top can work.


I few months ago I was having issues with a fresh install and I was pointed to the new docker based install. I downloaded Hypriot image 1.5 and flashed this to an 8GB and 32GB sd card, followed the instructions and everything went without a hitch. This was with 2 rpi3s.

I’m now trying to create a clean install for a test machine in my office and am using an old rpi box (gen 1?).

I took the exact same docker image which I have on a local drive and started up the box. The image installs fine and I’m able to ssh to the box. However, now when I try to execute the command docker pull brewpi/brewpi-raspbian and get an error message about the docker service not running and permission denied. See below.

My question is, why would the same image work twice and then fail? Would there be a incompatiability between certain libraries needed for the older pi box? If there were some incompatibilities I would expect larger issues just getting it up and running. There were no reported issues during start up.

Warning: failed to get default registry endpoint from daemon (Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Get http://%2Fvar%2Frun%2Fdocker.sock/v1.33/info: dial unix /var/run/docker.sock: connect: permission denied). Using system default:

I was setting up the old school raspberry PI and arduino set up and I got a bunch of errors trying to run the automated version of the install script.

Does this no longer work?

I use them with my glycol set up and run different temps on different fermenters.


I wanted to drop a thank you to this group and the team at BrewPi! My old repurposed laptop running my Ubuntu software acting as web server finally took a dive on me. Fortunately it didn’t impact the brew already underway as the script was already loaded on the BrewPi. Anyway I had to build another machine up.

This time as I had newer hardware to build on, I did an Ubuntu 18.04 install. In reading online through the BrewPi wiki, I decided to install via using the Docker. Following those instructions, I needed an older Ubuntu, but chose to install VirtualBox instead to run Ubuntu 16.04.

Long story short, other than a couple of user rights issues between VirtualBox and my main OS, and enabling USB on the VirtualBox (which are challenges of my own doing because I chose to use VirtualBox), all instructions regarding Docker and BrewPi installation worked exactly as they should, and I got my BrewPi software up and running again pretty quickly. This went much faster than the first time I installed the software (pre-Docker days). Installing via the Docker was great, and I wanted to pass along great job!

My first brew since the rebuild is in the fermenter now!