Alternatives to an RPI

I’m sure everyone will be using a different system to get the web ui up and running and the data logging, I can’t remember exactly how so i won’t go into too much detail about that.

So instead of the RPI i’m going to move to CHIP the $9 computer which i bought through Kickstarter. the unit comes with: onboard storage (4gig) and built in wifi and bluetooth, and as far as I can tell (i’ve not actually brewed with it yet) it’s not dropped out or shutdown in about 2 weeks so i’d say it’s as stable as the RPI, a fair chunk cheaper, smaller and it was wifi and storage built in too, it’s based on debian OS

I’m not sure whether the onboard storage will mean it doesn’t corrupt if there is a power outage but fingers crossed it doesn’t

I had to do some trial and error to get it working using the manual install (i think that/s because a new version of Apache adds another directory) most of my error came through me logging in as root rather than as “Chip” and that’s purely because i didn’t know what i was doing.

So if anyone is looking for a small cheap alternative in the future this could be a good option.

1 Like

Hi mikmonken,

How are you getting on with the CHIP?


I actually gave up on it. They updated the firmware which removes some libraries that were required for brewpi and meant it no longer worked properly so I put it in a draw.

When it was working though it worked fine.

Bugger, bought one when it was on kickstarter been sat in a drawer just got around to playing with it, thought it might be ideal to replace the rip.



they may well have updated the firmware again to rectify the issue, I seem to remember it that it stopped recognised the Arduino as a serial port, so I’m sure it was rectified, I just gave up I wanted to brew and had an RPI that was already set up and working.

I keep thinking maybe I should dust it down again and give it another shot

@Trig I had another bash at setting this up yesterday and whilst I can get it going, I find the Chip really unstable, you definitely can’t power the ardunio from it, it just cuts the power directly to the CHIP and it shuts down, that might be because my USB cable and phone charger aren’t up to scratch but, you also need to deactivate the wifi power saving mode etc to make sure it stays connected to the wifi.

All in all, and purely from my experience, CHIP was a bit of a waste of money!

Similar experience here, managed to load all the brewpi stuff on, I powered the Brewpi with its own power source and all seemed to work, however failed to keep logging the data after a few hours. I am mid brew so haven’t fiddled with it any more, plugged the rpi back in. Shame really as the chip is quite a neat form factor. Looking forward to the next software release.


Hi, Just had another fiddle with the CHIP. Did a fresh install of Debian then ran the Brewpi install. All appears to be working, has been rock steady for the last 24hrs with the Brewpi doing its thing perfectly. No wifi dropouts.


I’ve got it running on CHIP too, seems stable but I haven’t put a brew through it yet (I’m building it for a mate).

I used the CHIP for the last 6 weeks or so, had three brews through it no problems at all, until I tried to update to the latest BrewPi release. I’m no expert but the BrewPi ended up just displaying a white screen couldn’t do anything with it.
After running the updater all seems to go ok, until going into DFU mode and the error message “/bin/sh: /home/brewpi/utils/downloads/dfu-util: No such file or directory” running continuously.
I assume there is a difference in the file structure, naming etc between the RPi and the CHIP. I couldn’t work it out.
I rescued the Brewpi by doing the update with an RPi3 which my son gave to me.
Normality has resumed.