Basic starting up


Yes, Hypriot is an operating system optimized for running Docker and you’ll need to flash an image of it to the pi. You can read about it here.

You can follow the brewpi wiki instructions for flashing it to your SD card (here), or Hypriot’s own instructions (here, but slightly outdated). In fact, it wouldn’t hurt to first read through all three links posted above to familiarize yourself with the process before choosing one set of instructions and following them step by step to install.

You could also just install docker on raspian (I for example have my pi running the media-center os OSMC and have docker running in the background) but it might require some customized steps that would be hard to guide you through).



Thanx for your answer.

Is it correctly understood: I use either Raspbian or Hypriot, not both?



Yes. With the small exception that hypriot makes an ARM docker debian package that you could install on Raspian if you really wanted. But it’s simplest to use hypriot the OS, not hypriot the debian package.


Went back to starting up the BrewPi again. Previously, it worked together with my PC. When I hold setup the light isn’t blue but blinking red. SOS, 1 blink, SOS, 1 blink,… Suggestions are most welcome. Cheers.


That seems to suggest a Hard Fault (see here).

Could you explain what you were doing leading up to the LED flashing this way. Including both the state of the Spark and then anything you did.

For example “The Spark booted into test mode, but wasn’t connected to wifi so I held the setup button for 4 seconds to put it into listening mode so I could set up wifi”.


I will try to recapitulate. I coupled the BrewPi to the Pi thru a USB cable and applied 12V. It seemed OK. Pressed setup, got the blue. Tried the Particle app on my Android. Didn’t work, but had blue all the time. Turned BrewPi off and on. After that only red after 5 sek setup. Tried reset, 10 sek setup…, just red.


Can you still enter DFU mode? I think you need to reflash BrewPi over DFU (USB).


Roger, will try this, probably next week. Where do you suggest I find the most detailed instructions for this task: “Reflash BrewPi over DSU (USB)”?



I think I have docker running successfully on Raspbian. Raspberry Pi 3 model B.

pi@raspberrypi:~ $ sudo docker container ps
e807a20ba253 portainer/portainer “/portainer” About an hour ago Up 42 minutes>9000/tcp portainer
4a4effae5ca9 brewpi/brewpi-raspbian “/ /wat…” 3 hours ago Up 42 minutes>80/tcp, 81/tcp brewpi

I have reflashed the BrewPi, relase 0.5.4.
The BrewPi lamp is “breathing cyan”.
The portainer window is “Script not running”, sample data.

What can I do to further debug?


Seems to be working now

Commented Port = Auto in config.cfg.


I had to install Brewpi on the RPI with Rasbian OS due to WIFI connection issue with Docker (Hypriot OS).


Things are working for me now!

I would like to be able to access my BrewPi on Raspberry Pi from another computer at a different location. I would like a secure channel.

I was considering a web server on my R Pi. Seems like a solution with a great number of obstacles along the way.

However, my good news to you is that I found and installed a solution. It works! The answer is Team Viewer!


The stuff is running on a stability test here now.

Since 16:15 yesterday afternoon it has entered “script not running” two times. The “the start BrewPi” har no effect. When I unplug and replug BrewPi power, I get “script running” and things are normal again

Is there a remedy to this situation?



There are some wifi stability issues that Elco is working through. The most severe one (which was causing multiple lost connections per day) he fixed in the most recent updated firmware (which you may or may not be running). The other one sees the spark stop responding to TCP requests. It’s still annoying but for me at least it only happens once every 2-3 days, so I can live with it. Elco is still working on a solution to this, but it requires trying to get info from Particle (the maker of the microcontroller inside the Spark) on what exactly is causing the problem and what’s the best way to fix it.

I wouldn’t be surprised if he finds a fix sometime in the next few weeks. In the meantime, if you absolutely can’t stand losing the connection, reconfiguring the pi and spark to communicate via USB would probably eliminate connection problems. One key point is that the spark is still running and controlling temperature even when the connection drops. So your beer is fine, you just lose logging while it’s disconnected. It’s annoying, but it doesn’t affect fermentation and I can live with it while a fix is developed.


After updating firmware in Spark 3 to v0.5.4 2 weeks ago I have not been bothered with this much.
Has worked flawlessly the past week.


Now I have the BrewPi and the Raspberry Pi running together with SSR relays and control lamps. When in cooling mode the cooling lamp is on and off in about a 7 sec period. I think I have default settings. Any suggestions as to how I should go from here.

I have an .mp4 video, but this community page won’t accept that format.


That doesn’t sound normal. The default period for cooling PWM is 20 minutes. What is it set to?
You can try resetting to defaults, there is a button for this if you scroll all the way to the bottom.


The error seems to be in the SSR.Solved!

Do I need to set the clock on the BrewPi on spark? If so, how do I do it?


No, the data is timestamped by the pi when it is read from the controller.


Hi again.

1} Where can I find some good experience and guidelines on tuning PID?

I have just run a step response from 6°C to 20°C with water in the fermenter. It shows some overshoot.
2} Perhaps I could apply a Z-N approach?

3} Also, where can I find a header for the csv file?

This weekend’s events has generated some more questions.

When I started up my testing, I had brew=>fridge parameters like kp = 2, Ti = 7200… After doing Reset Controller to Factory Defaults from the bottom of the page, it comes out with kp = 5 and Ti = 10800…
4} What is happening here?

5} Is there a difference in parameters when I do Reload Defaults from the top of the page or Reset Controller to Factory Defaults from the bottom of the page?
6} What is the button Receive from script intended for?

Greatful for all good help!