Beer set point not updating when running on profile


I have a BrewPi Spark and all was working fine. However, on my most recent beer, when running in profile mode to ramp up the beer temperature, the beer set point never changed. For instance, if trying to ramp from 65F to 70F, the beer set point just stays constant at 65F. I’ve looked at the logs and beer set point is not changing. Thoughts?


I’m dumb…time/date on Pi was wrong for some reason and NTP wasn’t working. Problem solved!

Hello, Im new to this forum, this title seemed appropriate to ask my question instead of opening a similar topic. I noticed initially when i run my beer profile, the beer setting in the profile wold reflect in the display, beer setting displayed 50.5 (running in beer profile mode) and this matched my profile setting for the given day and cooling worked perfectly. I then wanted to do a diacetyl rest and the corresponding day was set to 65.5. The problem i noticed is that the beer setting no longer matches what is set in the beer profile. Is the algorithm changing this? Or is this a problem? Im assuming it is a problem since heating will not occur to make it reach its temp since the beer setting being displayed is lower than what is set in the profile.

I find your message a bit hard to follow, so I’m guessing:

If you are changing an already running profile, it is usually a good idea to click ‘insert now’, which will insert the current temperature setting at the current time. This will make sure that you are not changing the part of the profile that has already passed.

Can you make a screenshot?

I apologize for the confusing description. you guessed correctly, I did change an exist running profile, I imagine that was the issue, since I decided to abandoned the running profile and created a new one specifically for the diacytel rest period, and it is working. In the future I will be careful when updating an existing profile to use the insert now button. Thank you for your response.