Bootloader disabled?


I’m trying to add my second Spark, but Bootloader is disabled. When can I try again?

Thanks in advance for your reply.


If your Spark is connected to your Wifi, it will automatically update the bootloader.

I skipped the command brewblox-ctl bootloader and gave in the command brewblox-ctl wifi, added ssid and password, but don’t know what to do next…

Can you please help me out?



Does the Spark boot correctly? If so, then your bootloader is correct.

If you’ve also flashed the firmware, then you’re done with the spark itself.

Run brewblox-ctl editor to add the second spark service there. To finish, add the service in the UI. has a manual on adding a second service. I do see now we forgot to remove a reference to the bootloader there. I’ll fix that tomorrow.

Thanks for your reply Bob, but I’m afraid I need some more help.
I think my second Spark is ok, because it’s showing an IP adress.
I understand I have to open docker-compose.yml to see the service that manages my first Spark and copy/adapt it. But what commands do I need to run to do this?
Some info: my first Spark is connected to my Pi3, my second Spark is connected to my iMac.

You can access the docker-compose.yml file by running brewblox-ctl editor in your brewblox directory, and then going to PI_IP:8200 in your browser. (replace PI_IP with your Pi’s IP address)

The instructions for adding configuration can be found at describes how to configure your connection settings. In your case you’ll want to use --device-host=SPARK_IP (replace SPARK_IP with the IP address your Spark is showing).

Thanks Bob, I managed to copy and adapt the Spark-one in the docker-compose.yml file. To me, this is quite an achievement for now… :wink:
After the command brewblox up, my Spark-two seems to be running, but on Spark-one the blocks can not be found…

I don’t understand how to configer them and have them both running… I would like to have both Sparks to be connected to my Pi3 by USB.

Could you please run brewblox-ctl log, and post the result?

You can connect both Sparks to the Pi for power, and then choose to use either Wifi or USB for communication.

brewblox.log (147.0 KB)

It looks like both services are set up correctly, but without a spark ID or address specified. They’re both connecting to the same Spark, and getting confused when they receive responses to messages the other service sent.

The solution is to set a --device-id argument in the command section of both services. describes how to find the device id (below the diagram).

An alternative is to look for S/N on the sticker on the spark itself, and copy that.

I don’t know what you mean, but there is no serial number printed on the Spark. Maybe you’re confusing the unique serial id of each spark with the FCC id that is printed on the sticker. This is the ID under which the radio module is licensed and is the same for all photons.

So the easiest way would be to connect them one at a time and copy the ID from the Spark device info block.

Thanks for your help Bob and Elco; I think they are working both now.
I copied the ID’s of the Sparks in the command section as described in the advanced tutorial, listing spark devices.