Brand New Spark 3 and Raspberry Pi 3 installation problems


#1

Hi there guys/gals,

Have been reading the forums here but unable to install the brew pi software…

I have followed the instructions at https://wiki.brewpi.com/getting-started/raspberry-pi-docker-install

I can’t get past the first instruction:

  1. On this SD card, there is a file called device-init.yaml

I can’t find a file called “device-init.yaml” on the SD card.

This is from the Download HypriotOS link version 1.7.1

Where to from here?

Thanks in advance.

Cavok


#2

Apparently this file doesn’t exist anymore in newer versions. I’ve been having the same issues and haven’t been able to set up WiFi.


#3

This seems to have changed to wifi.yaml. There is some info in the hypriot FAQ.

https://blog.hypriot.com/faq/

I have not tried the latest version myself yet.


#4

Thanks guys for the help.

I’ll start from scratch again. I saw on another post that they had success with HypriotOS 1.6.0, and see how it goes.

If I install docker from the operating system, does it matter which OS I install?

Are the rest of the instructions working??


#5

OK. I have done a reinstall of HypriotOS 1.6.0 and was able to edit the device-init.yaml file, so that problem is solved.

I have gone through the rest of the instructions, but getting stuck at the "Connecting the Brewpi Spark to the server.

The procedure states "Connecting the BrewPi Spark via Wifi… configure the port setting as follows
port = socket://192.168.1.100:6666

Where to set the Port Setting?

The port setting is set /home/brewpi/settings/config.cfg"

When I type this into Putty, I get the error “No such file or directory”.

I have set static addresses for the Spark and Raspberry pi… Spark is blinking cyan… Both are showing up on Fing.

The error log script says:

“Opening Serial Port.
Errors while opening serial port:
Could not find compatible serial devices”

Also, the “Script not running” error message is showing.

I connect to the Raspberry PI by SSH, no problems!

So I suspect that it is because I haven’t changed the config.cfg file… How do I do this??

Thanks in advance… I have tried to include as much info for people experiencing similar problems.


#6

When you created the container, you mapped a volume on the host, to /data in the container.

If you used the default command, the data at ~/brewpi-data on the host and at /data in the container.
To access it on the host, you should indeed just SSH into the pi.
To access it in the container, the easiest way is to go to the console of the container using the portainer web interface.


#7

Hi Elco.

Yes, I used the command exactly as in the instructions, ie:

docker run -d --name brewpi -p 80:80 -v ~/brewpi-data:/data -v /etc/timezone:/etc/timezone -v /etc/localtime:/etc/localtime --restart always brewpi/brewpi-raspbian

Further on in the instructions it says:

The port setting is set /home/brewpi/settings/config.cfg. You can use nano to edit it.

So are you saying then to use the command:

cd ~/brewpi-data
nano config.cfg

… and not the following (which is in the instructions?)

cd /home/brewpi/settings
nano config.cfg

I can find a config.cfg file on the microSD card, I tried adding the port there but it did not work :frowning:

Another symptom that I have is with Portainer. When I click on “brewpi”, then “console”, I get the terminal screen up. The cursor shows, however if I type anything, the cursor does not move and no characters are displayed on the screen.


#8

I sorted the issue out myself.

I used SSH to connect to the Pi.

The directory is located at /Home/pirate/brewpi-data/settings, NOT /Home/brewpi/settings as indicated in the instructions (to edit the config.cfg file to enable wifi).

All working now, including wifi.

This may save someone hours of frustration!


#9

You don’t need to use Hypriot anymore, to use Brewpi with Docker. The BrewPi documentation still says so but I think that’s a bit outdated.

You can just use the standard raspbian image and install Docker via this instructions:

This might also save some headaches with folder names/structure being different than expected


#11

I have updated the BrewPi container and the wiki:

https://wiki.brewpi.com/getting-started/raspberry-pi-docker-install

I think the process will be a lot easier than before.


#12

Hi Elco,
When powering up BrewPI Spark 3 for the first time with firmware 0.5.5, no IP address is shown on the BrewPI Hardware Test Screen. How to configure from the server without the IP-address?
Cheers Ken


#13

Hold the setup button for 5 seconds to enter listening mode. Then use the particle phone app to configure the WiFi credentials.

One it has an IP address, enter this in the web interface under maintenance.


#14

Hi Elco
Is is possible to control more than one BrewPi Spark with different IP addresses from Brewpi server, that runs on Raspberry PI.

Cheers Ken


#15

With the docker version, you can easily deploy 2 containers and have each connect to a different BrewPi over WiFi. You will have to run each container on a different port.