Brew - error - stable ferment temp, but UI not cooperating

Bob I get the following error message
Error: no such option: --name

My bad, missed a word. It should be: brewblox-ctl add-spark --name spark-one --force --device-host

thanks Bob hopefully that fixes the issue. I replaced the with the static ip I have setup for the spark.

1 Like

down again.

Just tried power cycling the spark and restarting the brewblox services. Still getting nothing. When i use the brewblox-ctl discvoer-spark command it returns the wifi info with the ip address that matches the ip displayed on the spark.

Now its back, looks like it lost connection to the spark around 11pm last night.

3/26/2020: Update.
looks like the spark keeps loosing connection. Had to power cycle it again this morning to force a reconnect.

Would a usb connection direct to the unit be more stable?

Very likely. Most bugs we’re aware of happen or happened to wifi connections.

As an addendum to this - first brew went well! 1.056 OG down to 1.008…nice. I’m on my second and now I’m getting this error which seems to go away if I refresh my browser or just leave it for a minute. Temps seem stable.

Happens every time I go back to look at the GUI…

The dor next to the spark service is also red, indicating it lost connection. Could you please run brewblox-ctl log?


I’ll need a link =).

If you don’t have the output anymore, you can re-upload the file by running

cat brewblox.log | nc 9999

Sorry, I thought it sent you the link itself…

You seem to have had some unspecified controller resets, but otherwise nothing dramatic.

Browsers will kill background tasks and long-running connections in tabs if you leave the tab or go inactive for a while. By the layout, I’m assuming you’re on Mac?

I’ll make an issue to make the reconnect smoother. Until then, refresh the page when you see this, and you’ll be fine - the backend is still running smoothly.

Yes, I’m on a mac…

. The controller just went beep so I think it just reset itself…new log uploaded:

Yes, that’s a watchdog reset (triggered by controller hangup). I’d recommend updating to the latest version. We fixed multiple issues that can cause these hangups.

Ok - thanks Bob, I will upgrade.

Update worked but when I try and flash the Spark, the following error appears:

Oh dear. Hotfix is building, and will be done in a few minutes. link

For this release, brewblox-ctl flash is advisable (others have had issues with the alternative), but in the future you can also update in the UI. It will offer to do so automatically, and doesn’t require stopping all your services.

I actually did it from the UI first but it failed (Because I didn’t have the USB cable in) but by the time I realized I had already switched to doing it from the CLI. The CLI told me to make sure I have the USB cable in…Thanks for the hotfix, I will pick it up once it’s done, I may need some guidance on how to run it so I don’t mess it up.

It’s done building now. There are no additional steps: run brewblox-ctl flash and it will download the latest version and run it.

Pretty slick! Ok, that seems to have stabilized things…

Thank you & my young beer thanks you!