Brew - error - stable ferment temp, but UI not cooperating

I’ve recently set up a new Pi4/Spark and I’m getting this error continuously. I reboot and the temps seem to be all good but I’m wondering where to start troubleshooting so that it’s stable and I don’t keep rebooting my Pi.

Could you please run brewblox-ctl log? These errors indicate your service is unable to connect to your controller.

It looks like the output from brewblox-ctl log went here:

Logs indicate everything is up and running. If you refresh the UI, are you getting errors?

No, it’s running as of now. I thought the logs might be historical so we could see what happened. It happened like 3 or 4 times and then seemed to settle down. If it’s a case of running the brewblox-ctl log command while it’s happening, I will do that and post back here. Thanks!

Your log includes a reconnect due to a controller hangup.
If it happens, you don’t need to restart the Pi: it either disappears by itself, or when you restart the Spark.
When restarting the Spark, the service will automatically reconnect when it’s online again.

Needless to say, we’re hard at work improving the reliability of the service <-> controller connection.

No worries, I know we are still in the early phases of the product so I expect we may run into things like this which is why I’m posting, just to let you know so you can fix/improve things. I also will stop restarting my pi, its just my default action…lol

I’m having the same issues with a recently setup raspberry pi4. Switched back to my raspberry pi 3 will be keeping my eye on it.

Still having issues.

brewblox-logs.json 2.txt (1.6 KB)

Your log indeed shows multiple watchdog resets - some almost immediately after connection is made.

I’m all but certain that the problem is on the Spark side, and not caused by the Pi. What were the issues with the Pi4?

There seem to be some leftover blocks from previous configurations. If you’re still using default settings, you may want to clear them out and re-run the wizard.


How do I clear everything out and rerun. I assumed the issues were stemming from the pi4 WiFi as that kept dropping out. I’m having no WiFi issues connecting to my old pi.
I have a static pi set on my router for the spark, which has always been displayed on the sparks screen. I have been working from home today and did hear a few random reset beeps from the spark. for how to remove all blocks.
You’ll also want to remove dashboards created by previous wizards.

We have been seeing some weird interaction between IPv6 and restarting docker images, which was improved by disabling IPv6 on the host (
This may be related to the issues on the Pi4, but if the Pi3 is working just fine, there’s no pressing reason to change that again.

Thanks Bob. Cleared blocks, deleted dashboard and recreated. I’ll keep you posted.

Everything seems stable on mine now - no random spark reboots and my recent brew is blub-blub-blub-ing along nicely.


Still having issues, both the spark and rpi show up on my routers attached devices.

If you power cycle the spark, does it reappear? Next release includes a fix for mDNS discovery occasionally disappearing.

Your log also seems incomplete. Was there an error while generating it?

i didn’t receive an errors. Just power cycled the spark and now it appears to be back up for now.

here’s a log I just ran.

Seems like it cannot find the Spark using mDNS. You can add --device-host= to skip the DNS search and use the IP directly. Make it a static IP in your router so it doesn’t change.

We are waiting for Particle to release a new system layer, because the last release candidate has a firmware flashing bug. When Particle releases, we will also release updated firmware to handle this better.

In the meantime, using a fixed IP will probably help.

luddite here, where would I add the info Elco?


brewblox-ctl --name spark-one --force --device-host