Brew profile cant add any details

hi all

got the unit set up when I go on the web interface to set up a brew profile it will let me put in a brew name and select the time and date but cant add any info in the lines below to set up the profile and sometimes just brings up the date and time box again I try the start now and the other 1 but still cant enter any info in on temps and days

Hi trevor:

  • That is the profile name, not the brew name. These are 2 separate things. The brew name is changed by clicking the name in the top bar. That starts a new data logging set.
  • The ‘start now’ button just puts the current time in the start date field.
  • In the table below, you should be able to click the ‘days’ field and enter a number. This will automatically add a second row. You can also add rows with the right mouse menu.

If this is not working for you, please tell me which browser you are using.
Als try hitting F12 and click on the ‘console’ tab to see if there are any JavaScript errors.

hi Elco

I pressed F12 and console with no errors coming up still when I go into setting up a new profile I click new and enter the name and when I click on the rows it just puts the curser back in the name box same when I try the start now wont let me enter any information to setup and run a beer profile just has the sample brew and that’s it cant edit or run my own profile everything else works fridge mode and beer mode

using internet explorer

this is what I have come up with when I use my ipad I can edit a new profile and save it and run but I cant edit on my laptop I can only change between modes also while im on my ipad in the top left with the display it says can not receive lcd text from python script which im not to stressed about might help with what is wrong I get the display on my laptop just cant edit or setup new profile and I have tried other browser on my laptop but it wont connect

I can confirm the issue on Internet Explorer. I also get the data picker popout showing up all the time, stealing focus from the input fields. Please try Google Chrome and I’ll get onto fixing the issue for IE.

I have fixed the bug that the datepicker opens automatically in IE (in the develop branch).

It automatically gets focus as the first tabable element. Fixed by setting tabindex=-1.

The table is not editable because TD elements cannot be made editable in IE. :pensive:
See the issue here for details:

It can be fixed by putting the text not directly inside the TD, but inside an editable span.
Anyone that wants to take this? @bschwinn, @Lukas_Demetz
I’d prefer to focus on the bugs in the firmware.

If you want to receive an open source license for IntelliJ IDEA to work on this, shoot me a PM.

Elco, I’ll have a look at this tomorrow

@Elco, should be fixed by now

hi thanks for your help when I use chrome on my laptop it works fine do I need to do a update or anything on the rasp pi to be able to get it to work on IE or just continue to use Chrome

Hi James,

if you use Chrome nothing to worry about. It is a bug (aka “feature”) of IE, which fortunately was easy to solve, but it’s still not merged in the repository. If you stick with Chrome you should be fine :smile: