Brewblox assistence

#81

I have created my own block arrangement (for RIMS) and it’s working, yet the Block Relations view remains empty. Thoughts?

#82

Which browser are you using? Do you get any errors in the browser console (ctrl+shift+i for FF/chrome)?

#83

Browser: Chrome
Host OS: Windows 10 (also tried on Windows 7)

Some errors in the console … chrome_errors_win10.txt (1.2 KB)

Note that when I used the Wizard to create a Classic BrewPi arrangement, the Block Relations diagram was populated. Then I deleted all the blocks that I could and started adding my own. Not sure if this is helpful or relevant.

#84

Thanks, that info will indeed be helpful when trying to reproduce the issue.

#85

Marginally related to the above, all the blocks I created in the past and including all the blocks created by the “Classic BrewPi” arrangement in the Wizard all seem to still exist somewhere (even though I deleted them from the web interface). This can be verified by creating a “Graph” (on a Dashboard) and choosing which data to show on the graph. All the old blocks are still there. In addition, if I try to make a new block using the same name as one I previously created and deleted, I get an error saying that the name must be unique.

Q1: How to actually delete old blocks?

Q2: How to reset everything … to start from scratch?

#86

The Graph will let you choose from old (deleted) blocks. The history data was saved under that name, and is not updated when the block is deleted or has its name changed.

There is a distinction between Widgets and Blocks in the UI. Blocks exist on the controller. Widgets display Blocks, and are a UI thing.
The Spark page displays all your Blocks. You can immediately delete them there. When deleting a Widget, it will ask you whether you also want to remove the Block.

To completely reset everything:

  • On your Pi, run curl -k -X DELETE https://localhost/spark-one/objects to delete all blocks on the controller.
  • Still on your Pi, in the brewblox dir, run brewblox-ctl setup, and let it replace the history and datastore directories.

In related news: the fixes for the relations diagram will be included in the next release.

1 Like
#87

The curl command suggested above returns:

405 Not Allowed

I tried as pi and as root.
I did this while all the docker containers were running (assumed that was required since it’s accessing localhost via http).
Is that the expected output?

#88

Expected output is a 200 return code, and an empty object {}.

It indeed requires docker containers to be running, and assumes you’re still using the default name for the spark service (spark-one).

You can also skip that step for now, and directly run brewblox-ctl setup. When prompted, choose to keep nothing.

If you still had user blocks on your spark, you can delete them in the spark service page in the UI after the reset. Their name will start with ‘UNKNOWN|’.

#89

Ahha … I had changed the spark service name.

I ran setup again, overwriting everything, and all is good. This “reset” process will come in handy as I continue experimenting.

Thanks for all your help, @Bob_Steers, and from everyone else who has posted on the forums. I realize this software is not GA yet, so I’m really appreciative of all the quick and attentive responses!

#90

Happy to hear it worked.

For experiments: BrewBlox settings are contained in the brewblox directory. Multiple installations can co-exist, as long you do not run them simultaneously.

Note that the Spark stores its own blocks. You can persist/load controller state with savepoints (spark service widget) that are saved in the datastore.

Technically it’s possible to run two systems at the same time, but that requires further tweaks, and beefier hardware than a Pi.

#91

I can’t set up the classic brewpi dashboard in BrewBlox because I don’t use the top pin or bottom pin on Spark.
I use onewire for heat, cooling and temperature sensors and onewire is not a choice in the setup (Wizardry Arrangement).

#92

Please add the DS2413 actuators before you start the wizard. We’ll look into expanding the wizard to include that.

If you clicked discover, it will have discovered a DS2413 chip. You can create 2 ActuatorDS2413 blocks on the Spark service page. One targeting the DS2413 chip channel A and the other channel B.

The wizard will include those in the menu once they exist.

#93

I’m not quite sure if I understand what you mean.
This is how BrewBlox looks when I start it up for the first time, 2 DS2413 Chip discovered.

Is there a manual that I can study, hoping that I might understand some of this.

#94

Development is still moving too fast for extensive manuals - especially if we’re working on them not being needed.

That said: in Wizardry you can create DS2413 actuators, and link them to the discovered DS2413 chips.

When you have the actuators, rerun the arrangement wizard, and you can choose them as heating/cooling pins.

#95

I fully understand that there are busy times at the moment, so I do not expect answers to this comment.
I have created DS2413 actuators and linked them to the detected DS2413 chips, but still can’t choose them as a heating / cooling pin in the arrangement wizard.

It wont help to click discover sensor either.

#96

That does seem like a bug on our end. Issue for it at https://github.com/BrewBlox/brewblox-ui/issues/538.

Meanwhile, a workaround is to select actuator pins as output, and after completing the wizard, switch those out to DS2413 actuators.

You can see which blocks you need to edit by viewing the relations diagram in the Spark service page: edit the blocks that have an arrow pointing to the pin actuators.

1 Like
#97

Thanks for the quick response.
I’ll try your suggestions :slight_smile:

#98

Hi Bob,
I have a simple question that concerns me, on creating dashboards. I created a few test boards on my windows pc that runs Google Chrome. After creating the dashboards, I went to my brewery where Brewblox back and front end are running on two different PI’s. The front end is running with a full version of Rasbian installed including Chrome. The dashboards I just created on the windows pc is however not shown when I start up the “client PI” and runs Brewblox front end from Chrome. Why’s that? I thought that the created dash boards were “stored” on Brewblox back end end not on the client?
Cheers Ken

#99

This should indeed be the case. Do you get the dashboards when you restart your browser on your windows pc?
Are your services running?
Are you sure you’re visiting your backend with your other Pi, and not a different installation?

#100

I just restarted Goggle Chrome on my windows pc, and the dashboards I just created are no longer there which explains why I could not see them on the client PI either. How do I save dashboards then?

Cheers Ken