Hi guys,

I’m trying to install this service, I edited the files like it said but nothing is working yet. I’m new to this and know very little code. Do I have to install something first before editing the files so I can import recipe from brewfather?
what command would I use to install the service to my system?

Thanks for the help,


Could you please run brewblox-ctl log, and post the result link? That will show your current configuration.

At the moment, the service is still controlled by sending manual requests. Instructions for this start at GitHub - fdewasmes/brewblox-brewfather-service
is this what you are looking for? or a copy past of all the information.

The link is what I wanted.

Your immediate problem appears to be a formatting issue in your docker-compose.yml file. Yaml is a indentation-based format, and your brewfather: line is not indented.

You’ll want to edit your docker-compose.yml file, and indent brewfather: with two spaces, so it is in line with tilt and spark-one. The lines below are fine, and should not be modified.

I edited my file. I tried to paste this “” in my browser and I get a 404 error.
Shouldn’t this open a web page? I also re booted my system after making changes to the yml file. is the IP address of the Pi?

Did you run brewblox-ctl up after rebooting?

I did not run brewblox-ctl up after rebooting but I did log into the brewblox interface and verify it’s reading the temp for my fermentation fridge. is the IP of the Pi.

If the UI is still running after a page force refresh (ctrl+F5), then brewblox is currently active.

Could you please run brewblox-ctl log again?

I ran brewblox-ctl up and it said pulling brewfather . My network crashed before it was able to finish. Not sure why. I think I’m getting close. I’m doing all this remotely from work. I might have to wait until I’m home.

Thanks again for the help.

The log is incomplete, but it shows multiple errors that suggest a system-level issue.
When you’re home, could you please run brewblox-ctl restart, and then brewblox-ctl log again? It’s very possible a restart and brewfather image download will untangle most of the problems.

Everything looked a lot better this time. It actually said it installed things relating to brewfather.

still can’t access a swagger web page using ```

The service exited with an “exec format error”, which happens if the docker image wasn’t build for the Pi, but only for desktop.

The service is still in development as well. @Fabrice_Dewasmes may have to weigh in on whether he thinks it should be used already.

Ok, I have buster installed on a laptop. Maybe I can get it to work on there.
I’ll post if I get it working on a different version.

Thanks for taking the time to help me. It’s appreciated.

Hey there,

I confirm I develop from my laptop and the image is made from there. Didn’t have much time to work on this lately.
Is there anything special to build for both platforms @Bob_Steers ? I can throw an eye during the week.

Building is a matter of enabling the toolchain, and then using the --platform arg. It’s not special, but crosscompiled builds are much slower.

# per session
docker run --rm --privileged multiarch/qemu-user-static --reset -p yes
docker buildx create --use
docker buildx inspect --bootstrap
# build
docker buildx build --platform linux/amd64,linux/arm/v7,linux/arm64/v8 {ARGS}

Tangent: I’m working on the mash stepper block right now. If you think it’ll be useful to you, I can include you in the API review process.

Thanks. Would definitely be interested in the API yes.

1 Like

If this service gets fixed so it will work on cross platforms could some body post that it is working so I can give it another shot.

Thanks greatly,


1 Like