BrewBlox install error

brewbloxissue.txt (3.1 KB)

I’ve tried installing BrewBlox several times, but come back to the same issues. not sure what’s going on. I would like to automate the brewing/fermentation process and decided to give this a try. I have a raspberry pi 3 B+

There is a new version of the Raspberry Pi OS. Docker hasn’t yet updated its install script.

I’ve released a quick fix (thanks @j616s) to brewblox- ctl. To update run sudo pip3 install -U brewblox-ctl.

Afterwards you can run brewblox-ctl install again.

still getting an errorbrewbloxissue2.txt (3.7 KB)

if you run curl -sL | sed 's/9)/10)/' | sh manually, does that work?

brewbloxissue3.txt (266 Bytes)
doesn’t appear to.

Relevant issue:

The easiest workaround (if you don’t have a pi 4) would be to use raspbian stretch instead of buster.

As suggested in that thread:

sudo rm /etc/apt/sources.list.d/docker.list;
curl -sL | sed 's/9)/10)/' | sh


  • Edit /etc/apt/sources.list.d/docker.list
  • Change line to: deb [arch=armhf] stretch stable
1 Like

the first solution worked.