Brewblox install impossible?

Hello, since yesterday I’m trying to install brewblox on my raspberry pi with the instructions on the brewblox page and it errors every time. I used different Pi’s, different SD Cards and different power cables,… After each failed installation I started to google but i’m a big raspberry/docker noob and nothing seemed to work (or I didn’t understand it). After the 8th time i stopped trying, because this error keeps appearing.

“sub-process/usr/bin/dpkg returned an error code (1)”

Is there any solution to this problem? I do not understand how it’s always the same error with new, clean SD Cards and even different raspberry pi’s (3 and 4).

Thank you for your help,

Dpkg is part of the apt/apt-get package manager used to install software on many versions of Linux.

It sounds like you already thoroughly ruled out hardware issues.

What was the install output before the error?
If there wasn’t really any error info, could you please run brewblox-ctl -v install for more detailed output?

Used your command and got this:

pi@raspberrypi:~ $ brewblox-ctl -v install
Do you want to install with default settings? [Press ENTER for default value ‘Yes’]

INFO Docker is already installed.
A reboot is required after installation. Do you want to be prompted before that happens? [Press ENTER for default value ‘Yes’]

INFO Installing apt packages…
SHELL sudo apt update
Hit:1 buster InRelease
Hit:2 buster InRelease
Hit:3 buster InRelease
Reading package lists… Done
Building dependency tree
Reading state information… Done
All packages are up to date.
SHELL sudo apt upgrade -y
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following package was automatically installed and is no longer required:
Use ‘sudo apt autoremove’ to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up docker-ce (5:19.03.12~3-0~raspbian-buster) …
Job for docker.service failed because the control process exited with error code.
See “systemctl status docker.service” and “journalctl -xe” for details.
invoke-rc.d: initscript docker, action “start” failed.
● docker.service - Docker Application Container Engine
Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Thu 2020-07-23 17:14:01 BST; 19ms ago
Process: 11058 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock (code=exited, status=1/FAILURE)
Main PID: 11058 (code=exited, status=1/FAILURE)
dpkg: error processing package docker-ce (–configure):
installed docker-ce package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
Command ‘sudo apt upgrade -y’ returned non-zero exit status 100.
pi@raspberrypi:~ $

I’ve seen this error before I think. The Docker install succeeded, but it failed to immediately start.

You can likely fix it by rebooting the Pi with reboot. Afterwards, run docker version to check.

If the output from that shows version info, restart brewblox-ctl install. It will detect docker is already installed.

It worked! Thank you very much!