BrewBlox install

I am trying to follow the instructions for installation of BrewBlox.
On - Step 2: Enable SSH and WiFi I unzip the Headless files but cannot seem to get the application started.

Which archive did you use? (portable or installer)
Did you extract all files?
In the archive, what file did you start?

I used both. Portable gave me a warning from Windows.

The one I showed you before is from the installer.

File Headless Pi.application

I have now downloaded “this archive” and copy-pasted the two files to the boot drive. The file wpa_supplicant.conf is now modified. Am I ready to go to the RPi or du I still have a problem with Headless?

You can continue with the install. The Headless Pi program and the archive containing ssh/wpa_supplicant.conf are alternative approaches to do the same thing.

It looks like you ran into some Windows security settings. I just tried it, and only got a warning about an unidentified publisher.
I know relatively little about signed Windows applications, so I think @LBussy will have to weigh in on that.

Edit: for the record, I’m pretty sure I permanently disabled Windows SmartScreen. That may have made the difference.

Good, thanx! I live in hope.

I did not digitally sign the application for three reasons:

  1. I’m inherently lazy at times and I could not be bothered. You’re already downloading and running unsigned code on your RasPi anyway, so why bother? It’s likely not as bad as some of the other stuff people run. :slight_smile: (“someday” I may look into it)
  2. I believe there’s still a cost, and I’m not paying for it for something I give away for free
  3. I provide the source code as an ultimate representation of what I am doing, you don’t have to trust anyone but yourself.

You can click on “More Info” and there’s an option to run it anyway. That’s your path.

Definitely not suggesting you should go the extra mile to get your application signed.
I’m aware that the associated costs are something even we as small company would balk at.

If this is just a case of SmartScreen being annoying, I’ll add a note to the install guide about it.

1 Like

Thanks Bob. I’m just being belligerent this morning as I was up all night and my coffee is not even touching it. :slight_smile:

1 Like

Thanx for the good work guys. It was not clear to me that we had two alternative options here.

I’ve work myself down to where I should see 6 boxes on a black background. I see only black background. A breathing blue light. I have run brewblox-ctl flash after brewblox-ctl setup. Should I rerun brewblox-ctl setup?

No, that just means that your Spark does not have a bootloader yet. I assume you’re installing this on a Spark you already had?

Scroll a few lines down for the bootloader command.

I have just a black screen and a breathing blue light.

Have you flashed the firmware? (brewblox-ctl flash)

Edit: it also can happen that the connector to the LCD screen was not seated correctly.
After flashing, continue with the install. If the UI/service can connect to the Spark, but the screen is still black, then it’s time to take a look at that.

The bootloader is the last command. I flashed the firmware before that one. Should I redo?

Before I started on the BrewBlox the BrewPi was installed. The screen was behaving normally then.

I might add that there is som small text on the lower part of the screen. Should I send a picture of it?

Sure. There should indeed be text there, and in this case a picture always helps.

Now I do not really know what to say. My camera sees these boxes, but they are (almost) not visible to my eye. The BrewPi screen, before upgrading, was very visible.

The good news is that it’s working.
I wouldn’t worry about these boxes being dark - they’re the “nothing shown here” placeholder.

Actual blocks displayed are much brighter, and clearly visible/readable from a few meters distance.

Yepp, good news. I will let it rest for the evening now. :first_quarter_moon_with_face:

Increase brightness of background items noted.
There is also a brightness slider in dthe display settings block, but it defaults to 100%

Another problem today. On my R-Pi Chromium is causing the processor to freeze. What is your experience here? Can you suggest an alternate browser?

I hear Firefox on the Pi is pretty decent:

On the whole, we do suggest using your own computer for the UI. Browsers tend to be fairly heavy.