Brewblox not running after update

Hi Bob,
Tried an update today and now not coming up properly - getting a message:
Inrelease changed its suite value from stable to oldstable.
log file is rxxn
Can you advise.
Many thanks

Could you please copy the full output from what I assume to be the brewblox-ctl update command?

Here it is

pi@truffles:~/brewblox $ brewblox-ctl update
INFO Updating brewblox-ctl…
INFO Updating brewblox-ctl lib…
edge: Pulling from brewblox/brewblox-ctl-lib
Digest: sha256:fd50edde968ee898317e007e1a3c90cb5394aec194313ef653628e1cf7b2def9
Status: Image is up to date for brewblox/brewblox-ctl-lib:edge
INFO Stopping services…
Removing network brewblox_default
WARNING: Network brewblox_default not found.
INFO Updating apt packages…
E: Repository ‘Index of /raspbian buster InRelease’ changed its ‘Suite’ value from ‘stable’ to ‘oldstable’
Command ‘sudo apt -qq update && sudo apt -qq upgrade -y’ returned non-zero exit status 100.
Command ‘/usr/bin/python3 /home/pi/.local/bin/brewblox-ctl update --update-ctl-done’ returned non-zero exit status 1.

If you run

sudo apt-get update --allow-releaseinfo-change

and then retry the update, does that work?

Lots of errors, here are the last lot
ERROR: for spark-one Cannot start service spark-one: failed to create endpoint brewblox_spark-one_1 on network brewblox_default: failed to add the host (vethc6 f8eda) <=> sandbox (veth2d9cee0) pair interfaces: operation not supported
ERROR: Encountered errors while bringing up the project.
Command ‘docker-compose up -d’ returned non-zero exit status 1.
Command ‘/usr/bin/python3 /home/pi/.local/bin/brewblox-ctl update --update-ctl-d one’ returned non-zero exit status 1.

You may need to run

brewblox-ctl down --remove-orphans
sudo reboot

Then startup, and retry.
If you post errors, please copy all of them. It’s very likely that the first ones and the non-error output are relevant.

Had kind of the same problem :

E: Repository ' buster InRelease' changed its 'Suite' value from 'stable' to 'oldstable'
Command 'sudo apt -qq update && sudo apt -qq upgrade -y' returned non-zero exit status 100.
Command '/usr/bin/python3 /home/pi/.local/bin/brewblox-ctl update --update-ctl-done --prune' returned non-zero exit status 1.

These commands fixed it :

sudo apt update --allow-releaseinfo-change
sudo apt -qq update && sudo apt -qq upgrade -y
/usr/bin/python3 /home/pi/.local/bin/brewblox-ctl update --update-ctl-done --prune

The second command on that list might take some time to finish, don’t worry and grab a homebrew while waiting :beer::wink:

Lastly, if promted for it, run the following command :

brewblox-ctl database from-influxdb

You should have a working instance of Brewblox at this point. Check your UI for the next steps.

1 Like

Many thanks all

Got it up and working again, so will start a brew today.

Hi Bob
I have done another update, this time it seems all is running, but cannot see anything in brewblox - it keeps spinning saying waiting for datastore.
Any ideas?
Many thanks

Could you please run brewblox-ctl log?

Is this what you need?

Your services are down. Try running brewblox-ctl up, and then reload the UI.

Hi Bob
I have started the services, same issue with the UI, here is the log

pi@truffles:~/brewblox $ brewblox-ctl up
brewblox_history_1 is up-to-date
brewblox_ferment_1 is up-to-date
brewblox_redis_1 is up-to-date
brewblox_herms_1 is up-to-date
brewblox_spark-one_1 is up-to-date
brewblox_eventbus_1 is up-to-date
brewblox_victoria_1 is up-to-date
brewblox_distill_1 is up-to-date
brewblox_traefik_1 is up-to-date
brewblox_ui_1 is up-to-date

It’s complaining about data corruption. Could you please make a snapshot and share that? Data could be recovered, but I’ll have to look at it in more detail.

Probably a silly question, how do I locate it, so send to you?

Upgrading your system | Brewblox contains instructions for exporting snapshots.

Afterwards, pick a file sharing service of your choice.

Processing: brewblox-ctl.tar.gz… (49.2 KB)
Processing: brewblox-ctl.tar.gz…
Thanks I have added it

Sorry to say, but that’s the wrong file. You want /home/pi/brewblox.tar.gz, this is /home/pi/brewblox/brewblox-ctl.tar.gz.