BrewBlox: Problems Making Certificate Request

I just tried to setup BrewBlox on a newly setup raspberry pi and I ran into this error after executing " brewblox-ctl setup":

I still wen ahead and tried " brewblox-ctl up", seems like it runs through without errors, but then in the browser I see this when trying to open the interface:

Is that related? Any hints on how to fix? Could it be that a space I used in the organization name (“Chicco Beer” could be causing that?

So I ran the setup again with " brewblox-ctl setup", this time without using any spaces and that seems to have fixed everything.

Good to hear!

As the certificate is self-signed, and for internal use only, it’s also pretty common to just leave everything blank.

Thanks for the quick reply!

Right, not a big deal and I do not need any further help for right now. Maybe a hint about that would make sense during the setup just to avoid people running into this.

@Bob_Steers Any hints on where to find the docker-compose ID? I am trying to setup a service in the webinterface and it says that should match.


For trying to setup a new Spark service, the docker-compose service ID is the header in the docker-compose.yml file.

snippet from the file (the ID is spark-one):

    image: brewblox/brewblox-devcon-spark:${BREWBLOX_RELEASE:-stable}
    privileged: true

In docker-compose ps the names are formatted as directory name + service ID + instance number. brewblox_spark-one_1 means the first spark-one service in the brewblox directory.

The long letter/number combinations you got from docker-compose ps -q are not relevant when changing your configuration.

Edit: by default, the spark-one service should already be available in the UI.

First time I loaded the UI I did not see the default service, second time I deleted it cause I thought it was one that was somehow added and I wanted to make sure everything is configure properly. So now I have to add one manually.

My docker-composer.yml:

@Bob_Steers I am not sure if I understand your answer. So " spark-one" is what I would have to enter in the ID field when creating a new service?

That’s correct. It will do a http request to verify, so if you can add it, it’s the good one.

1 Like

Thanks for the very quick support! Will verify tomorrow and let you know how that worked out.

Feels like a stupid question, but there’s just zero documentation. How do I enter my SSID. Typing it and hitting enter does nothing.


Typing it and hitting enter is how it should work. It may be an issue with automatically skipping the wifi scan.

You can try and run it manually:

docker run -it --rm --privileged brewblox/firmware-flasher:rpi-edge

This changes the shell prompt. You can enter the following commands here:

./particle --no-update-check serial wifi

I can simply not enter anything. After I type something and I then hit enter, I am stuck forever.

Same here, stuck forever.

Ohhh, reboot of raspberry and brewpi fixed that.

Weird, but happy to hear it works now