Brewblox release 2023/01/09

Relevant links:

Brewblox release 2023/01/09

firmware release date: 2023-01-06

We’ve continued our work on improving the Builder. This release this includes a rework of how part settings are edited. In both the editor, and layout widgets or pages, you can right click (long press for mobile) on parts to show their settings in a context menu.
Parts that have settings are highlighted on hover.

In another change, we’ve also simplified how the PID calculation is presented.
The integral and derivative are now unit-less values derived from P.
This changes the calculation overview from:

Error      * Kp      = P
Integral   * Kp / Ti = I
Derivative * Kp * Td = D


Error           * Kp = P
Integral of P   / Ti = I
Derivative of P * Td = D


  • (feature) Builder part settings are now editable in context menus (right click / long press).
  • (feature) Simplified the PID calculation display by making I and D based on P, and not Kp.
  • (feature) Added the option to export graphs as PNG with transparent background.
  • (feature) Pump parts in builder now have a configurable on-click behavior: toggle or show dialog. Toggled PWM blocks are enabled / disabled.
  • (feature) Added the Display: Image Builder part. This shows a given JPG/PNG/SVG image URL in the builder.
  • (improve) Parts in the “new part” dialog in the Builder editor now show placeholder values instead of “block not found” errors.
  • (improve) The PID now always gradually decreases the integrator, instead of instantly resetting it to 0.
  • (docs) Moved all Tilt service documentation to
  • (fix) When cached PID integral values are loaded after controller reboot, they are no longer immediately reset.
  • (fix) onscreen keyboards now again correctly spawn a numpad layout for numbers and quantities.
  • (fix) fixed rendering error where onscreen keyboards would have a small horizontal scroll bar.
  • (fix) PWM on the OneWire GPIO module now correctly goes to 100%, instead of 99.2%.
  • (remove) Removed the “Edit Settings” tool from the Builder editor. Part settings are now editable in context menus.
  • (remove) Removed support for the automation widget from the UI.
1 Like

After updating to this release (both soft- and firmware), I cannot select temperatures for graphs any more, only the PIDs with integral/derivative show up in the data selection. Normally, there was a lot of data to select from.

The temperature is shown normally in the spark blocks or in my other items on the dashboard:

I’m at a loss where to find the temperature data. The spark and fridge do work without problems, but it would be nice to see the pretty colourful lines again. :slight_smile:

Are the fields selectable in a metrics widget?

If you force reload the UI, do fields reappear?

Force reload or different browser (edge vs. firefox) do not help.
I don’t know what a metrics widget is. But when I select the temperature sensor in the spark blocks overview and select “graph” from the pull down menu, it says “no data”.

I have to admin that I’m still using the same brewblox setup and dashboard as I did when I first installed it a couple of years ago, so some stuff might be outdated, but up to today I’ve never had problems.

Oh one more thing. In firefox, I can’t select the temperature sensor/setting widget to set a temperature, whereas in chromium (edge) it just works fine. That’s kinda weird, especially since it worked again earlier today just after updating brewblox and now it doesn’t.

I’ll be happy to chat about this tomorrow sometime in Discord, then I might make more sense. :smiley:

The Metrics widget can be created in Wizards → new widget. It’s like a graph, but only displays the latest value.

Could you please run brewblox-ctl log?

Thank you Bob.
I checked again right now and all the data fields are back again. The widget is clickable as well, everything works as before. Apparently, patience was the remedy (like so often).
Sorry for bothering you. :slight_smile:

Good to hear it’s working again now!

I suspect the problem involves the browser still using some cached portions of the old UI. It resolves itself in the end, but it’s still something we’ll want to look into, and ensure it works the first time around.

1 Like

I am a few updates behind. I am running Brewblox-ctl update, but in the process getting this error:

Err:4 Index of /raspbian bullseye/main armhf Packages
Undetermined Error [IP: 80]
Fetched 15.0 kB in 6min 4s (41 B/s)
Reading package lists… Done
E: Failed to fetch Undetermined Error [IP: 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.
Command ‘sudo apt-get update && sudo apt-get upgrade -y’ returned non-zero exit status 100.
Command ‘python3 -m brewblox_ctl update --update-ctl-done’ returned non-zero exit status 1.

This is on a Raspberry Pi 3

This looks like a DNS / server issue for one of the apt download servers. MS Azure has been having outages, maybe it’s related.

You could retry sudo apt update to see if it resolves itself, or do a ctl update without system packages to skip it entirely for now: brewblox-ctl update --no-update-system-packages

Thanks @Bob_Steers that fixed it and allowed me to upgrade to the latest. You are the best!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.