Brewblox + Spark 4 no connection

Hello. I have massive problems with spark 4 controller. My log,:

Please help me.

The Spark service itself looks fine. Your history database is facing some file corruption, with the container restarts having a knock-on effect on other services.

You can check whether this helps:

brewblox-ctl down
mv ./victoria ./victoria_bak
mkdir ./victoria
brewblox-ctl up

This moves existing history data so the database has a clean slate. If this fixes the issue, and you want to keep your history data, we can then look at manually fixing the corrupted file.

Thanks a lot Bob, that helped.
Please, can the system also work offline? My problems started today when I updated Windows and then Spark 4

I’m not sure what you mean by “offline”. All the code runs on your Pi and your Spark.

I control Spark 4 through a web browser.
After starting in windows cmd via

cd /home/pi/brewblox
/home/pi/.local/bin/brewblox-ctl up

does not want to open the browser http://raspberrypi/ui/service/spark-one without an Internet connection

You need a connection between your browser and the Pi, but you don’t need a connection between either your browser or the Pi and the internet.

My setup: Spark 4, Pi, Laptop with Windows OS and Lan Switch. All 3 peripherals are connected via LAN cables via a switch. Sometimes I can’t start the brewblox system through the browser when I don’t have an internet cable connected to the switch… Now controlling brewblox through the browser works even when I’m offline. I don’t understand why not always where I make a mistake…

If this is just a switch, then the important part is that the cable is connected to the router. It’s not important that the router is connected to the internet, but you need the router to give your devices an IP address.

1 Like

Hi Bob,

again, I can’t get into the brewblox control via the browser. I have all the devices connected to the Router, as you advised me. Internet is not connected. I log in to brewlox via Windows CMD, everything works correctly, only I can’t start the control via the browser. What should I do please? My firewall is turned off

MY log:

The docker daemon is attempting and failing to reach a DNS server at, and your services are not running.

Unless you’ve edited the setting on your Pi, this is typically set by the router, and then propagated to devices in the network. Check your router settings for DNS settings. You can try changing it to or

“All 3 peripherals are connected via LAN cables via a switch.”

A switch or a router?
If it is just a switch, you have no router/gateway/DNS server on the LAN, which would explain what’s happening.

Thank you Bob. Works great with dns change on router