BrewBlox Tilt Service

No, my bad. It’s docker-compose restart datastore.

Some more info on the issue:

Thanks! No, I really appreciate all the help. It is processing now. Will let you know if I continue to have problems.

Ok. I think that I have fixed the datastore issue. Basically, just need to wait a long time after running the restart script.

However, can you help me troubleshoot why my TILT hydrometer is not being picked up. The bluetooth dongle is right next to fermentor which is stainless. I have a usb bluetooth dongle attached to a USB extension cord running outside the freezer and into the rPi. I can get the signal from my phone. And at least for a few days this set up worked fine.

It wasn’t until I tried to run the calibration settings the 2nd time that I lost the connection.

Once again, any help is greatly appreciated.

There’s no support in the code for multiple bluetooth receivers at the moment. The code is likely just connecting to the built in bluetooth receiver on the raspberry pi and not the dongle.

Does the raspberry pi 2 have built in bluetooth?

Ah. No it doesn’t. But the interface to your dongle likely won’t have the right name. But using a raspberry pi 2 will probably explain why you were having issues with it taking ages for the data store to come up.


Well dang. I’m about to give up. Would it be possible to use a bluetooth dongle on a rPi 4 instead of the onboard bluetooth?

I had the bluetooth dongle working fine before trying to edit my config file. What gives? I didn’t move the usb to a different usb slot.

Really? I think it worked by luck more than anything else tbh. But if it worked before, I see no reason why it shouldn’t now. Did you perhaps unplug and plug it back in? It could have been assigned a new ID if you did. But as I say, dongles aren’t “officially” supported. I don’t have any bluetooth dongles to make it work properly either.

I mean it worked for a good 24 hours or so. This is the only photo I have.

Yeah I unplugged it because I was having a wifi issue (different thread).

It’s very clear that the Tilt hydrometer will not send a strong enough Bluetooth signal to be heard through the stainless conical and freezer. So, best solution I could think of was a usb extension cord and honestly when first installed worked fine. The power cycle messed it up somehow.

I also ferment in a stainless conical inside an upright freezer. What I’ve done successfully in the past is to “move the mountain to Mohammed”, in other words I run the Raspberry Pi inside the freezer so that the Tilt’s Bluetooth signal only has to span some fermenting liquid + the thickness of the fermenter wall. The WiFi signal emanating from the cold RPi is sufficient to link up with the rest of the home network. Admittedly it doesn’t hurt that one of my WiFi access points is just above the freezer.

Caveat: my past experience has been with BrewPi, and I haven’t yet done attempted this setup since getting my Spark3 and changing to BrewBlox.

Yeah thanks for that. It’s a bit of a conundrum. I didn’t want my rPi to be in there if I was going to run the freezer for very long to cold crash or what have you. I may try this but all of my actuators are in a project box mounted outside the freezer so would be a total changing up of how things are wired/organized. I wish the Brewblox/Tilt service could work with bluetooth dongle and not the onboard BT. If that changes in the future I may come back to Brewblox (wink wink, @j616s). As it stands, I am trying to get what I need from my $20 inkbird controller and logging gravity/temps with Brewer’s Friend/Tilt Pi and the BT dongle/USB extension cord.

I have my relays & such in a project box too. But with my new BrewBlox setup I rarely have the Pi and the Spark physically connected via USB. So my controller / switching logic sits outside (on top of) the freezer. The RPi and the various temp / SG sensors are inside the freezer. I have cold-crashed with the RPi in there, with no apparent long-term harm. Once the beer is fully crashed I sometimes move the RPi outside the freezer since by that point there are no longer relevant SG changes to track. Hopefully you’ll get the BT dongle working soon and can experiment similarly.

Thanks. That’s a great idea. I have a spark v2 but I guess I could upgrade to rPi 4 and mount inside freezer. Then, connect to the spark/project box with a long USB cord.

A new rPi and a $60 BT repeater from TILT are sounding pretty good about now.

I am using the tilt service now for the first time and it looked promising at first. But two days ago it stopped logging. I thought maybe the battery was empty but after doing a brewblox-ctl down and up it worked again. What can cause this? And is there a way to reboot only the Tilt service instead of the whole brewblox?

‘docker-compose restart tilt’ assuming tilt is the name of the service.

As of why the restart us needed, @j616s can hopefully help with that.

docker restart brewblox_tilt_1 is the command you want, Ithink

As for the issue, when did you last update? I pushed a fix for needing restarts about 2 weeks ago that seems to have sorted things on my end

I think I am using the last version, I installed it 1,5 week ago I think.
Updating is done with brewblox-ctl update right?

That is how you update, yes.

Is there anything useful in the logs?
docker logs brewblox_tilt_1

I’ll check this evening. I didn’t get SSH working over VPN so I can’t check at work :slight_smile: