Brewblox update error

I tired to update my brewblox software and I kept getting a weird error: “error pulling image configuration”. So I just decided to remove and reinstall brewblox. The install went well but when I tried to run “brewblox-ctl setup” I get the same error I was getting at first:

"pi@raspberrypi:~/brewblox $ brewblox-ctl update
brewblox-ctl requires extensions that match your Brewblox release. Do you want to download them now? [Press ENTER for default value ‘yes’]
SHELL docker rm ctl-lib
SHELL docker pull brewblox/brewblox-ctl-lib:edge
edge: Pulling from brewblox/brewblox-ctl-lib
6e1a744202a5: Pulling fs layer
error pulling image configuration: Get dial tcp i/o timeout

Error: Command ‘docker pull brewblox/brewblox-ctl-lib:edge’ returned non-zero exit status 1."

Any idea what’s going on?

For the vast majority of errors, reinstalling is a bit overkill =)

This error means the servers over at Docker are having some (temporary) problems. It should work when you retry in a bit. If it doesn’t, we’ll have a look at a workaround to force the download to use another of their servers.