BrewBlox update problem

I shut down and restarted. Same problem. Running the spark thru a USB cable.
Tried to go on the Pi and use Chromium. Still no success.
No contact for UI thru IP adr.

Could you please run brewblox-ctl log?

Here is the screenshot.

Typically it’s easier to copy the termbin URL, as the log was uploaded there =)

Your logs show your system being online and working. Are you sure you have the right IP? You can also try visiting https://raspberrypi.local

Edit: think I’m overlooking something, if it had issues reading blocks from localhost.

Could you please run

docker ps | nc 9999
sudo netstat -tulpn | nc 9999

and copy the two termbin URLs?

Hi again Bob,
I guess I am not uptodate on everything here.
What/where is termbin URL? Will that give more information compared to the screenshot?

When you run brewblox-ctl log or a command ending with | nc 9999, it will print a URL in your console.

In your screenshot, that was When you (or I) visit that URL, it will show the command output that was uploaded to termbin.
Every time you upload something, you get a new URL.

Yepp, and here is what happened. I tried and understood.

Yes, and that means it’s easier for everyone if you just copy the URLs into a forum post, instead of making a screenshot.

More on topic: it somehow managed to skip the part where it listens for HTTP requests.
The services are running, but not listening.

Try running

brewblox-ctl restart
docker ps | nc 9999


Here is the latest.

Output suggests everything is up, but those timeouts are the docker-compose equivalent of a rattling sound: something is not 100% ok.

If it now works, then fine. Otherwise:

brewblox-ctl down
sudo apt update
sudo apt upgrade -y
sudo reboot

and then when it restarted:

brewblox-ctl up

It works now, but I experience that it doesn’t work after shutdown and restart.

I think I will leave here for this evening and see what happens tomorrow. If it doesn’t work, I will run these commands and see then. Anyway, I will let you know.

Thanx for now, Bob.

1 Like

Good morning Bob,
When I turned on this morning, the UI did not come up.
I ran the procedure you gave me. (ran the sudos from directory brewblox, hope that’s ok) )After that it came up.
I turned the Pi off and on, it did not come up again then.
Ran brewblox-ctl up and then it worked.
It seems to me that we need brewblox-ctl up for every Pi restart. This started to happen after the last BrewBlox update. Hope this is helpful.
Looking forward to your response.

The sudo commands included stopping Brewblox (the brewblox-ctl down command).

It’s a good idea to run brewblox-ctl up after Pi reboots. You can safely run it even if Brewblox is already started.

Yepp, it looks like it will work with a brewblox-ctl up for every startup.Seems I’m in B.
But, still I do wonder:
Am I the only person experiencing this?
Did I mess up the upgrade?
Would it make sense to rerun the upgrade?

Thanx for prompt response!

You didn’t mess up the upgrade, and re-running the upgrade would not change anything.
I’ll investigate if this is a wider issue, but it may be a change in how docker-compose works.

Goodmorning Bob,

I ran this:

brewblox-ctl down
sudo apt update
sudo apt upgrade -y
sudo reboot

and then when it restarted:

brewblox-ctl up

But it is stil not working…

What can I do?

Did you run brewblox-ctl update? Your last logs indicated that you had flashed your controllers, but your services were not yet updated.

Yes, I did.

This is what I see:

I found the problem: we made a typo when deploying the spark service under the alternative (old) name.

You can get the correct version by running:

docker-compose pull spark-one
docker-compose up -d
1 Like

Hi again Bob,

We are two guys here.

Should I run

docker-compose pull spark-one
docker-compose up -d