BrewBlox update problem

Hi folks,
I am not able to connect to BrewBlox UI.
I ran update.
Entering UI there was notice of firmware update. I ran it from the widget in the Spark controller. There were error messages and the sequence paused. I shut the system down, reentered and ran brewblox-ctl flash via putty.
As said, I am unable to connect the UI via the IP address.

Where do I go from here?

brewblox-ctl flash stops containers. Run brewblox-ctl up to start again.

It’s been stuck here for more than 5 min.

I seem to be impatient today.
Now I have

Hangups during create are often caused by swap memory overflow.
See for how to disable that.

Afterwards, run sudo apt update && sudo apt upgrade -y and restart brewblox-ctl up.

Happy to say: It’s working again.
Thanks, cheers

1 Like

Hi guys,

I ran in some trouble too I guess…
Both my sparks show they run the new software when I start them up, but I can not control them.
My screen shows the services are running, but no handshake etc. is performed.
Leds on the Sparks breath green, but on my iPad they stay red…

What can I do? I did a couple of reboots, brewblox-ctl restart, but no luck…



How are they connected? Do they show up in brewblox-ctl discover-spark?

Hi again, I’m back,
Been working, successfully, on BrewBlox all day. Turned it off for an hour or two, restartet. Now the UI will not connect on The IP.
Where do I go from here?

Can you ping it? Can you go to it with SSH? Otherwise just restart the Pi.

SSH works fine. Have restarted several times.

had something similar,
only one of my sparks had the device id in docker-compose.yml. adding the second device id seemed to fix it for me.

Connected via USB and they show up using brewblox-ctl discover-spark.

I am in contact thru SSH Did a successful discover_spark, so there is contact vi SSH
We seem to be two problem-people here. Would you suggest a restart for me?

@bartv80 You can run docker-compose up -d --force-recreate spark-one to reset your spark service. If that doesn’t work, can you please run brewblox-ctl log?

@BrewOfJohn You also have USB devices?

restart did the trick, I am back in B.

  1. What is the meaning behind Desired setting, setting and value.
  2. On the graph I sometimes see labels in brackets. Why is this.

I thank for all the wonderful help I am getting.


I am not sure what you mean by USB devices. I have the spark + mouse & keyboard on the Pi.

Desired setting / setting / value is explained here:

The default formatter for graph values is [block name] value unit => [Cellar temperature] Value C.
This is just a default. You can edit the label yourself by clicking on the node in the settings.

USB devices meant whether you’re connected to the Spark(s) over USB, but never mind if it’s online already =)

Thanks for your help Bob, but recreating did not do the trick.

Edit: nvm, it seems your services are currently out of date. You’ll want to run brewblox-ctl update first.

Controller firmware is latest. You don’t need to flash that. Both controllers are being discovered, so everything should work after running update.