Brewometer integration


#269

Hi @desmop, if you are using an arduino you do have to run the sudo ~/brewpi-tools/updater.py --ask command and set it back to legacy branch. [4].

Did you have the brewpi running prior to attempting this integration?


#270

This is an issue others have brought up back in Feb. Have you looked back at earlier posts. Here is one that may help you. https://community.brewpi.com/t/brewometer-integration/1674/225
I would suggest that you first install the legacy version of brewpi as the error message instructs. verify that works before making any alterations. Then when thats working make the modifications for the tilt hydrometer integration.


#271

Thanks Ron_K for the help. Everything was working fine before the integration of the "Tilt" file changes. I kept getting the brewpi log error that my version 0.2.10 was not compatible with the new 0.4.0 version script so it would halt. I had to wipe out /home/brewpi and www/var doing a complete refresh. Not sure I'm going to try it again. Thanks for the help.


#272

I also use the arduino version. Instead of following SBowlers instructions for the spark version, I found This repository that forked off of the original version, written for the arduino. have you tried this? https://github.com/supercow/brewpi-brewometer


#273

Thanks Ron, I will try this repository. I'll keep you posted on the progress.


#274

I followed the guide and installed everything. Given file permissions.
With test option I see the Tilt.
I can not, however, make the log on brewpi in graphical interface. You can not see anything.
In the log i have this error. What should I do?
May 06 2017 16:51:50 Found BrewPi v0.4.4 build 0.4.4-0-g6d17ff1, running on a Particle Photon with a V2 shield on port /dev/ttyACM0

Unhandled exception in thread started by >
Traceback (most recent call last):
File "/home/brewpi/TiltHydrometer.py", line 361, in scan
blescan.hci_enable_le_scan(sock)
File "/home/brewpi/blescan.py", line 79, in hci_enable_le_scan
hci_toggle_le_scan(sock, 0x01)
File "/home/brewpi/blescan.py", line 103, in hci_toggle_le_scan
bluez.hci_send_cmd(sock, OGF_LE_CTL, OCF_LE_SET_SCAN_ENABLE, cmd_pkt)
_bluetooth.error: (1, 'Operation not permitted')
May 06 2017 16:57:21 Notification: Restarted logging for beer 'test%20TILT'.
May 06 2017 16:57:36 Notification: Beer temperature set to 20.0 degrees in web interface

#275

Hi @kead,

This sounds like a bluetooth permissions problem. Can you try running again the setcap command, then restart the script:

  sudo setcap cap_net_raw+eip $(eval readlink -f `which python`)

#276

Nothing... i have try but same problems.
In web interface i don't have the line of Tilt.


#277

Hi,

Just trying to set this thing up from scratch. Fresh install of BrewPi up and running, and added the files from https://github.com/sibowler/brewpi-brewometer according to the instructions.
TiltHydrometerTest.py finds my Tilt (Blue)

But no graphs are showing
In the logs I find this error:
Unhandled exception in thread started by >
Traceback (most recent call last):
File "/home/brewpi/TiltHydrometer.py", line 366, in scan
returnedList = blescan.parse_events(sock, 10)
File "/home/brewpi/blescan.py", line 130, in parse_events
pkt = sock.recv(255)
_bluetooth.error: (32, 'Broken pipe')


I have tried to run the fixPermissions.sh scriptm but no changes made.


#278

Started a new brew sorted the graphs - awesome work!!

The error messages are still in the log though, anything I should pay attention to?


#279

Strange problems..
I installed the backup on dropbox. In the backup I can see the Tilt report! Nothing in local display bwp (as previous photo).
Another problem but related to Tilt: it is put into the water but the density grows now after hour (see this picture). Is it broken?


#280

Did you install the tilt integration part-way through a brew? If I remember correctly, the data won't show on the BrewPi interface until you start a new brew.


#281

I reboot the system, start a new brew, refresh page, change browser... the situation is the same :frowning:


#282

This indicates that the modified web files/scripts haven't been installed correctly. If you can see the graph in the dropbox version, then the data is being logged (this is good).

Can you double check that all the files in the brewpi-web/ folder have been copied over the original files in /var/www (sometimes Brewpi is installed in /var/www/html - so double check there aren't two copies of the files).


#283

Resolved! the correct folder is /var/www/html
Thank you!


#284

OK....My first attempt at this was a bust. At least the BrewPi is still functioning.

First question:

I assume I need to copy all of the sbowlers github files onto my RPi in the exact directory structure as indicated?

brewpi-script
brewpi-web
tiltHydrometer-test

....and then run the Setup and Testing instructions/commands?


#286

Hey, I just got my Tilt/Brewometer and I'm trying to get it working with my Pi/Arduino BrewPi (so Legacy branch).

I'm having the same problem that Richard_Crump did in this post:

Here is a screenshot from my BrewPi:

I am using jlvnyc's fork of the BrewPi/Brewometer mod (since sibowler's doesn't work with the legacy branch from what I've read)

You can see that it is showing all the possible Tilt colors, even though none of them have data. It is showing the data from my Tilt (Black) on the graph, but not on the sidebar. There is also no SG scale on the right side of the graph. It is also showing the temp from the Tilt in Celsius (that's less important though). The data from the Tilt do show up when I use the test script, and are being logged to the csv file. Basically the exact same problem as Richard_Crump in the linked post

I have "reinstalled" (recopied and overwritten the files) a couple of times, rebooted, restarted the script, refreshed the webpage. I used the fixPermissions.sh script to fix the permissions. I tried Richard_Crump's solution; making sure beer_chart.js was copied over (verified by modification time and by reading through the file to make sure it was the correct version), and chowning the www folder to brewpi, but neither of them seemed to help

Does anyone know what to try next?


#287

Just set up everything! Thanks to all for the documentation and work done. I got some issues but could solve them easily!!
Great!!!

Cheers,

Marc


#288

Maybe try Ctrl+F5 in your browser to force a reload of the files?

It doesn't seem like all the files have been refreshed... If you go in your webbrowser to http://<brewpi address>/js/beer-chart.js does it show the modified version?


#289

I don't know about Ctrl-F5, but I cleared browser cache and temporary files,and it started working. Unfortunately it still shows the Tilt temp in Celsius, but it I don't plan on using it.