Brewpi/Arduino "Default control constants"


A long time I am working on my Brewpi/Arduino but I’am going to achieve the test step…
The electronic is done, my actuators and sensors are OK, I’am just finishing the fridge hacking.
I was running the webserver and I don’t know why but I don’t have any default constants settings in the tab “Advanced settings”.

I tried the restore factory settings and even writing a ‘C’ over piLink but the situation is the same, all the fields are empty.
“Update from Arduino” and “Receive from script” don’t change anything.

An idea why default constants are not available ?

I have the v0.2.10 build and I am in temperature mode OFF.

Thank you for your help.


Is the script successfully connected?
Can you try to click the ‘reset factory defaults’ button at the bottom of advanced settings?


Yes I am pretty sure the script is running, here the log just after starting:

I have just tried, reset to factory settings:

And a reload defaults for control constants:

And my constants stay empty…

Nice error reporting with the screenshots! Thanks for that.

  • Did you run sudo python --ask and pick the legacy branch on both script and www?
  • Do you see ‘script running’ in the top right corner?
  • Did you click the ‘update from arduino’ (silly question but just in case)
  • Can you open the debug console (F12) and see if there are any JavaScript errors?
  • Did you make any changes to the web interface?

Yes the script is running:


When I click update from arduino the request looks fine in the chrome debugger:

But nothing change in the webpage and didn’t modify the web interface (only pinout in the arduino firmware)

Now I try to call with sudo:

I am not very familiar with Linux…
Now I try with su:

(sorry for the french… the command looks unknown)
I don’t find maybe you right I have a problem in my web package…

Thank you very much for your help, I hope you have another idea :slight_smile:

It is part of brewpi-tools, which I assume you used for install.

Don’t login as the brewpi user, just use the pi user.
And run the command in the directory where is located.

cd /home/pi/brewpi-tools
sudo python --ask

It’s better now ! Thank you very much and sorry It was my fault, I don’t know why but I was on the master branch of the web server.

Here the steps I have executed:

Now I have a beautiful page in “Control Algorithm” tab !

I have to finalize my fridge, just to connect the heater and after I can start to test the PID.

What is the best way ? Can I test and tune the PID with just a glass of water ?
But the inertia will not be the same than 20L of beer that’s why I’m not sure it is a test to do.
Should I test with 20L of water ?

Thanks again !

No, you should test with 20L. A glass will not be the same.