Brewpi Kiosk mode

I was wondering if I could get some idea how to finish kiosk configuration for a touch screen.

I have followed lots of the internet sites on the setup of kiosk mode, but when starting up it is asking for a password.

Can anyone let me know the syntax for putting the password in the autostart script.

Many thanks

Who is asking for a password? The Pi itself?

Hi Bob, it is the Raspberry. Was wondering how others set up their kiosk to login automatically, or do they need to manually do it each time?
I can log in to the display manually, but that seems counter intuitive. I do log in SSH externally to get brewblox on laptop.

Not sure what you mean. But I use this on a dedicated raspberry. Works like a charm!

1 Like

Log in on the Pi, and open raspi-config (sudo raspi-config)

System options -> Boot / Auto Login -> Desktop Autologin

Thanks to both - thought that I had set autologin, but will double check.

Also think a dedicated pi is a great idea - will do that as well.

Best regards

Tried both and they both worked nicely. Now will rebuild the raspberry pi for brewblox, to remove all added and build another dedicated pi for the screen.

Question? When using other pi, I could only use ip for webpage. Is there anything special I need to do to set it to host name on different ip?

Thanks in advance

Change the host name on your Pi to be something else than the default “raspberrypi”, and then try HOSTNAME.local. (for example: fridgepi.local).

You may need to restart both Pis before this works. If it then still doesn’t, check your router whether mDNS can be enabled.

If you’re using Wifi autodiscovery, then this should work, as it uses the same protocol.