Brewpi not connecting to local server

I went to change modes to ready my ferm fridge for my brewday tomorrow, and I can’t access the web server via another computer on my home network.

I rebooted the pi
I doublechecked the cat5 cable

No dice.
Then I logged onto my router, and it’s showing the rpi under the assigned IP address, but instead of DHCP, it says unknown.

So I pulled the rpi out of the mounting case, and hooked it to a monitor and a different cat5 cable. Same result.

Watching the system boot up, however, I see it says it can’t mount the Apache server.

Does anyone have experience with this?? I need to brew!

Worst case would be re-install. Either get a new card or reformat the existing card and download the NOOBS image from the RaspberryPi website.

Not much fun, but if no-one else has a better solution?

(BTW you can guess how I know about this solution, similar symptom)


1 Like

sigh. That’s what I was afraid of. Thank you for your input. At this point, it’s worth it just so I can get brewing tomorrow.

So all my data from previous fermentations will be gone. Unless there’s a way I can back that stuff up before reformatting the SD card and safely replacing it after.

Is this an issue with raspian or is it due to a shite SD card?

If it doesn’t boot, it is likely to be SD card corruption. If it does boot, it should be possible to get your data off the card.

You say you see logs about apache not starting. That looks like you can get on the command line?

Then you could insert a second USB stick and copy the data in /var/www/data to the USB stick.

I recommend installing raspbian lite instead of NOOBS.

1 Like

Welp, I reformatted the SD card with raspbian jessie lite, and when I booted up the ol RPi it wouldn’t connect to the router. All the LEDs on the corner of the RPi board were lit solid (and stay lit solid even if the ethernet cable is unplugged).

Am I dealing with a bad ethernet port here?

The worst part is I really want to brew tomorrow, but it’s too warm in my basement to ferment without control. I do have an old laptop I can reformat and use in place of the RPi while I wait for a new one, but I’m not sure what OS would be optimal. Linux? Windows?

Maybe try a WiFi dongle?

Both OSes would be fine. Windows with WAMP or Linux with LAMP.
The install process is a bit more involved. But you can just clone the two repositories. Try to run the brewpi python script and install any packages that are missing.

I was never able to get a wifi dongle working on my RPi. I tried 2 different ones for weeks and couldn’t do it. That’s when I just said screw it and ran a cat5 cable across my basement.

Is it bad that those LEDs are lit all the time? FDX, LNK, 100. They’re all lit - with the cable plugged or unplugged.

Are you using a power supply specifically designed for the Pi? When you have a lot of strange issues, it could be that the pi is underpowered.

Strange that the LEDs are lit indeed. Did you test this cable with a laptop? Could it be wired incorrectly?

I should have mentioned: I’ve been using the brewpi on this RPi for over a year with no issues. Same wire, no changes.

Yesterday, when I discovered it was inaccessible through my home network, I first rebooted the pi, then checked the router software to discover it wasn’t granted DHCP access.

“Bad cable” was my first thought. So I pulled the pi out of its home with the arduino and brought it upstairs where I have a different cat5 wire and a monitor. So I’ve tried with 2 diff cables.

Hmm… strange. You did reboot your router, right? (I feel like tech support asking this ;))

Yeah, sure did.

A friend of mine has a spare RPi, and he’s going to lend it to me so I can (fry his, too?) determine if it’s a hardware issue.

So damn frustrating.

Okay, my friend lent me his RPi, and it connects to the internet with no issues. So I guess the ethernet port just got fried somehow.

I’m back in action now. Thanks for all your help, guys.

1 Like