BrewPi Settings Help: New Heater = Huge Swings


#1

I’ve been using BrewPi for a while and love it, but just replaced my lamp heater with a small personal plug-in / fan heater.

As you can see my beer temp swings are significant, 10 degrees or more. I reset all the BrewPi settings to factory to see what would happen, but really don’t understand the PID inputs enough to properly dial this in myself. Can anyone help?

I have actual wort in the fermentor going through these swings, and want to pitch yeast tonight or tomorrow morning, ideally with this fixed by then!

Thanks!

Brian


#2

I don’t understand why the sudden jump in setpoint happens, but it looks like your beer temp is above the fridge air temp at all times.

The arduino BrewPi algorithm only works well when heating the beer through the fridge air indirectly.

Try moving the fridge sensor so it gets some heat and try to prevent direct heat to the beer.


#3

Thanks @Elco for the recommendations… I just adjusted the locations of the heater and the temperature probes as you recommended. I’ll report back with an updated graph once enough time has gone by.

Picture of my fermentation set-up is below:

Previously, the heater was pointing at the carboy, and the fridge temp sensor was in the lower left hand corner of the chamber.

Also, I’ve been messing with the Kp, Ki and Kd values to try to streamline it a little bit based on other forum posts and the PID controller Wikipedia post. Probably should only modify one thing at a time now that I’m typing this out…

Right now my values are
Kp: 4
Ki: 1
Kd: 2


#4

@Elco it’s looking quite a bit better, not a huge timeframe to go by but only ended up over the target temp by .6 F…

I set the PID maximum at 10 earlier, which looks like it’s affecting the Fridge Setting on the cold side if I’m interpreting this right… but what I don’t know is if that’s “OK” or not, or should I make further adjustments?

Thanks for your help!


#5

It looks like your heater is a bit too powerful and heating the minimum time (darker red) is too much.

On the arduino version, the minimum time is not adjustable and there is no PWM to reduce power.


#6

@Elco thank you for your insight and help on this. I’ve seen the fact that you can’t adjust minimum heater time on previous posts.

Here’s a screenshot with a little more time elapsed… beer temp is quite a bit closer now, but I can tell the heater is pretty powerful for that small space:

Fermentation kicked in around the 08:00 point, hence the jump in temp without heater influence… After the second cycle around 14:00 taking a while to come down, I slightly increased Kd around the 17:00 mark and it looks like it potentially helped for the third cycle.

Current settings here:
Kp: 4
Ki: 1
Kd: 2.5

Given the heater strength being what it is… any other suggestions or tweaks you can recommend? I will keep messing around but any insight would be very much appreciated.

Thanks for a great product and great support!


#7

I would reduce kp, try to make the difference between fridge and beer temp smaller.