BrewPi to nothing works

I actually have no idea what is going on if I am being honest. I was running BrewPi. I don’t get to brew often and about 9 months ago when I brewed my BrewPi setup was not working right. I just started over and it was fine. When that ferment was done I just turned the temp adjustments off and walked away. Then the past weekend I tried to connect via attached monitor and the webpage would freeze half loaded, show the 2 temps and was not controllable. So…that beer is in the basement not in temp control…

I come to the BrewPi site and find BrewBlox…great I think…a new system…let’s do this! Cause when it worked…BrewPi was awesome.

Everything seemed to go fine until I was flashing my Spark and got the message below. Now the screen is lit but blank and if I navigate through a browser to the rasp pi IP I get connection refused. Please help. I am not a linux guy, but I follow instruction really well.

INFO Flashing Spark…
Flashing Photon…
Flashing System 1 file…

Flash success!
Flashing System 2 file…

Flash success!
Flashing Firmware file…
Error writing firmware: dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!

dfu-util: Error during download get_status

Command ‘docker run -it --rm --privileged brewblox/firmware-flasher:rpi-edge flash’ returned non-zero exit status 1.
pi@raspberrypi:~/brewblox $

Thanks in advance.

What color is the led light? Is it blinking / breathing?
If you retry the flash, do you still get the same error?

The combination of errors could indicate file system issues. Did you install BrewBlox on a fresh install of raspbian? Did you try a new SD card?

I tried it twice. I didn’t start all the way over the 2nd time, but I could.

What led are you referring too?

And yes, fresh install, I don’t own a second micro usb. If you really think that could be it i guess i can buy one.

The LED on the Spark (not the Pi).
SD cards are a common source of issues, but we’re also about to release an update that deals with some issues with flashing. That may solve it as well.

Will this work with a Spark 2? I jut realized that there is a 3 now, I looked at my original 2015 order here are the lines from it. Am I heading down a path that will never work?

### BREWPI SPARK V2 BREWING TEMPERATURE CONTROLLER brewpi_spark_v2 $144.76 $144.76
Temperature controller
1 x BrewPi Spark v2 normal (with enclosure) $121.73 brewpi-spark-v2 Ordered: 1
Shipped: 1
Include programmed Photon (only uncheck if you already have one)
1 x Particle Photon $22.34

The Spark 2 is still fully supported, and will continue to be. I believe the LED is visible on the back, but I don’t have one here to verify.

Thanks. I will take a look in a little while for it.

@Bob_Steers The LED is on the bottom on my unit and it is blinking blue. The cyan (connecting to cloud), or the darker blue (listening mode)?

Edit: does the problem still occur with the new release?

Blinking blue could mean it needs an updated bootloader.

You can use the particle app to set up WiFi and then it will download the bootloader from the cloud.

I know that which color is it should be an easy question…

It appears to be flashing at the pace of the Blue one and the color appears to be somewhere between then Cyan and the Blue.

Is there a link to instruations on the particle app?

Instruction below for how this should work, but while going through them again, my device refuses to connect. I’m getting the suspicion that Particle broke things on their end. You may want to try anyway to verify.

Instructions for connecting your device to the Particle cloud:

Install the app from android or iOS.

Create a Particle account here.

Run brewblox-ctl wifi if you haven’t already to connect your Spark to your home network.
In the app, log in, and then choose to setup a Photon. You will need to hold down the setup button your Spark. It can be accessed using a bent paperclip.

Perhaps brewblox-ctl wifi is enough. I don’t think a Particle account is required to download system updates. Not sure though.

In theory, these commands should also work over USB. The flash should succeed before the bootloader.

brewblox-ctl update
brewblox-ctl flash
brewblox-ctl bootloader

My wifi is flaky in the garage. I wonder if the receiver is just having trouble picking up the signal. If I disconnect the device and probes from it and bring it all inside to eliminate that as a potential issue should it still work?

I will try the suggested items as soon as I have a free minute.

Thanks for the quick replies.

You can bring it inside without any issues.

The commands that I gave all use USB btw.

So I have made progress. I ran the first update command that Elco provided and during that update the SSH connection dropped and I couldn’t reconnect. I brought it all inside the house and plugged it in and the spark picked up an IP address and has blank squares and says it can be edited in the web interface. That seems like progress to me. I will work on it more over the next days, but wanted to send a thanks before I turned in for the night.


Good, that means firmware is now installed and ready to use. For the rest of the installation you can continue with the getting started guide.

Ok…so now I was able to run the up command and get into the Pi via http and the GUI. When I run the fermentation wizard it just hangs on a blank screen. Screen shot attached.

If I got to the SPark IP address I get "Your BrewBlox Spark is online but it does not run its own web server. Please install a BrewBlox server to connect to it using the BrewBlox protocol.

Device ID = 1a0027000247343337373739"

Sorry to ask for more help, but what next? Should I just try to manually build the blox?