BrewPi V2 Restart Help

Hey all, I’ve got a Brewpi V2 and the Raspberry Pi that it is connected to has stopped working. I’ve got the replacement Raspberry Pi but what reboot procedure do I need to do to ensure that everything runs like it did previously?

The first install was in January 2017 so I am assuming that I need to run the latest installer. I think it was 4.4 the last time that I ran it.

We actually completely replaced the Brewpi platform with BrewBlox. It’s a major upgrade, but still supports your Spark v2.

Thanks! After completing the install of Brewblox my brewpi screen went blank and the blue light on the back started blinking blue. I tried to reset but that’s not working. Any ideas how to fix?

It needs to update the system layer and/or bootloader to run the new application. If you set up WiFi using the particle app, it will be able to download these from the cloud.

I appreciate the quick response Elco. So I’m pretty computer illiterate. I am however really good at following instructions. Can you clarify exactly what I need to do?

Just to update you on what I’ve done so far, here’s basically what I’m working with:

  1. I was up and running with the old version of BrewPi about 2 years ago just fine, then the Raspberry Pi that it was connected to died.

  2. I purchased a new Raspberry Pi and a new SD Card.

  3. I followed the instructions to setup BrewBlox and it seemed like everything was working until I got to the end of install. I am able to see the UI on my computer but it has an error message saying the BrewPi is disconnected. The BrewPi is a lit up blank screen and blue light is blinking.

  4. I currently have the BrewPi plugged into a Raspberry Pi that has the SD Card, and I am able to login via PuTTY to run codes.

Thanks again for your help

The Spark is waiting for a bootloader update and cannot run the new firmware until it gets one.

We normally recommend letting the cloud automatically handle that, but I think in your case it is a good idea to force the update over USB.

You can run the following commands:

brewblox-ctl update
brewblox-ctl flash
docker run -it --rm --privileged brewblox/firmware-flasher:rpi-edge flash-bootloader --force

I expect that you will get something on the display and will hear a beep afterwards.

Then run:

brewblox-ctl wifi

And enter your WiFi credentials.

Thanks Elco, So I’ve got the Brewpi showing 6 blocks and it says to setup on BrewBlox. However when I go to my Brewpi IP address I get this message:

Your BrewBlox Spark is online but it does not run its own web server. Please install a BrewBlox server to connect to it using the BrewBlox protocol.

Device ID = 2f0021001847353236343033

That’s good, it means the controller is installed. Everything else now happens in the web UI. You can also edit what’s displayed on the Spark LCD display there

Yes, go the the IP address of the pi instead.