BrewPi V3 - Step 1

Got my new BrewPi 3. I believe I have the wifi set up on it properly in accordance with the instructions. How does one get the green light back to the breathing “magenta”? Perhaps that’s not important at the moment.

I have downloaded the HypriotOS for my RPi 3B to the SD card. Trying to boot the RPi on (with) the HypriotOS, I get to the “black-pearl” logon screen. After entering the default user name: pi, it will not accept the user default password “raspberry”.

I assumed that HypriotOS was a stand alone operating system for the RPi. What’s the deal? Does it have to be “flashed” with NOOBS or Raspian?

At the black-pearl login try l/p: “pirate” / “hypriot”.

OK, thank you. F@(k, It says that on page 3 of 8 of the setup up instructions. Shouldn’t that be associated with step one?


It’s not needed earlier than this step:

But of course, the docs can always be improved. It’s a wiki, so feel free to edit the page to improve the clarity.

OK, got past that one.

Set up RPI wifi: Got it by editing the device-init.yaml file. Done.
Found the IP address of the RPi and successfully ssh’ed into it via Windows.
Configured the timezone. Done.
Updated with the latest raspbian image. Done

Deploy a new brewpi container…Got some errors. Repeated attempts indicated it already existed…

Got all the way to here:

My RPi is at
My BrewPi 3 is at Blinking green on the test screen.

What’s next??? There was nothing in the config.cfg file so I added the suggested script.

Tried the Particle Setup as suggested with no results.

Yea same here. I am trying to edit the config.cfg file but can’t find it. My programming isnt strong, so I am having trouble understanding where it should be. I tried nano /home/brewpi/settings/config.cfg and nano /home/brewpi-data/settings/config.cfg

Both just showed a “New File” that was empty. I am trying to edit the port so that BrewPi can read the spark via WiFi

Yes, the file does not exist until you change a setting.
Starting a new brew creates it.

You can also just copy config.cfg.example to config.cfg. I will add a few lines to the docker container so it does that when you create the container. That will be less confusing for people.

@rheinz Your container says ‘created’, not ‘running’. Maybe you should just start it and then go to the IP address of your pi.

AH there it is! Yup started a brew and now there is a config file. Right now it just has:

beerName = LightGermanAle
dataLogging = active
profileName = GermanAle

And simply adding-
port = socket://192.168.1.XX:6666

Should force it to search that IP for inputs?

Thank you for the help

Nevermind! Doing exactly that worked. Thank you Elco!

1 Like