Brewpi WebUI Not Starting Script

  • I am running 1 instance of Brewpi (0.2.10) with Raspberry Pints on a RPi2. RPints is in /var/www and Brewpi is in /var/www/brewpi, which is how I set it up through the automated install (installing RPints 1st). I would prefer it this way too since I plan to open it up to remote access from work using a login for the Brewpi (RPints comes with built in admin security).

  • The script starts at the initial boot fine and the CRON job seems to be working fine. If I stop the script from the Web UI, it stops and creates the “brewpido_not_run_brewpi” file in /var/www (not in /var/www/brewpi). It is owned by user brewpi and group www-data. However, if I click the start script button on the Web UI, nothing happens and the “brewpido_not_run_brewpi” file remains in /var/www . If I manually remove the file via the command line, CRON catches it, and the brewpi starts back up normally. I tried copying the “brewpido_not_run_brewpi” file (with same owner settings to match the original) to /var/www/brewpi, but the Web UI didn’t do anything to remove it from there either when I clicked to start the script.

  • So how do I get the script on/off button to work correctly from the Web UI? Is this not working because the button expects the index.php and the “brewpido_not_run_brewpi” files to be in the same directory, but they are not? I’ve seen plenty of posts indicating others run brewpi outside of /var/www and it seems to be working for them. Do I need to edit a file to tell it the real path to the “brewpido_not_run_brewpi” file? When I initially installed brewpi, I told it about the /var/www/brewpi location, I didn’t move it there after. I have tried a fresh install of everything (reformatted another microSD card and started from scratch), but continue to have this problem.

Here is my Cron:

entries="brewpi wifichecker"
# entry:brewpi
* * * * * brewpi python $scriptpath/ --checkstartuponly --dontrunfile $scriptpath/ 1>/dev/null 2>>$stderrpath; [ $? != 0 ] && python $
# entry:wifichecker
*/10 * * * * root sudo -u brewpi touch $stdoutpath $stderrpath; $scriptpath/utils/ 1>>$stdoutpath 2>>$stderrpath &

Thank you in advance for your help.

In /home/brewpi/settings/config.cfg, add

wwwPath = /var/www/brewpi

Thanks for describing your issue so detailed :slight_smile:

Sadly, @Elco, that is already what it says. I think because I stated that directory in the initial install. What else could be the culprit?

Does anyone else have any ideas to get this up and functioning?

Well, i figured it out!! It needs to be:

wwwPath = /var/www/brewpi/

That “/” at the end is key.