Calibrate sensors


#1

Hi
Just got 3 new sensors from Brewpi, two long and one short. The two long ones are reading the same temperature but the short one is off by almost 1°C. I’ve tried to calibrate by SSH in to brewpi, stop the script, run
$ sudo screen /dev/ttyACM0 57600
$ h{v:1}
$ U{i:0,j:-0.9}

But nothing changes. The sensor is reading the same temperature. Also trued with U{i:2,j:-0.9} but same result. This is the Legacy version with arduino. Any ide?


#2

For the Spark we have a field in the UI, for Arduino (which has been discontinued and is not updated or supported since 2015) we don’t have a UI option.

Calibration was fixed in 0.2.11 so you’d have to run that version.

The commands look correct. Perhaps try cutecom instead of screen.
Sending the command you receive from listing the devices h{} with “j:-0.9” added should work for the latest version that was released for Arduino.


#3

How can I check the version i’m running?


#4

I believe it’s printed when the script starts and when ‘n’ is sent over serial.
Also send a line end \n after each command.


#5

Thanks. Its v 0.2.10. How do I upgrade? sudo python updater.py --ask? or just update the Arduino?


#6

I think that’s the last version we released for Arduino.
The bug was fixed in 0.2.11 in this commit:

I don’t have a 0.2.11 hex file for you and don’t have the tools to compile for Arduino installed anymore, sorry.


#7

Hi Elco,

I compiled a hex file with the calibration offset fix included and posted it on HBT forum, if it’s not a violation to cross post and you don’t have an issue with it, I’m happy to provide a link for the OP?

Cheers,

Kal


#8

No, please do! You can also upload it here I think.


#9

Okay, great!

Here’s the hex file: brewpi-uno-revC-patched.hex (MD5 Checksum: ac1bd3b7ea2beff2363cf06068e65e93)

The patches merged were these two:

Hope this is helpful.

Cheers,

Kal


#10

I flashed you’re hex file but still couldn’t calibrate the sensor.