Cannot calibrate temperature sensors for Spark Photon

I have tried to follow the instructions here:

I’ve installed ‘screen’ on the Raspberry Pi with

sudo apt-get install screen

Then tried to stop the script running using the Web Interface (which seemed unreliable. Is there a better way to stop it?).

I then open communication to the Spark Photon using:

screen /dev/ttyACM0 57600

(you exit screen with ctrl-a, then k)

which gives me an initially blank screen. I followed the advice to first prepare the commands ( also found here ) in a text editor and to copy them, then paste the whole command into the command line.

When I paste in


I get output


Which looks like the temp sensor is at index 3 (which matches the device slot I assigned it). I’m assuming the other “i”:-1’s are the outputs?

So on the assumption that the sensor is at index 3 I copy pasted this offset command:


because I wanted to reduce the reading by 0.438C (calibrating using ice water slush after letting the sensor sit for some time).

I then get output


Which looks like it’s trying to tell me something went wrong? And the “j” value is not any different to what it was before. Rerunning the h{v:1} command shows basically the same initial output (the “v” or temperature reading was slightly different, but not by 0.438 degrees), also with an unchanged “j” value.

Am I doing something wrong? Are those instructions not valid for the current firmware of the Spark Photon (0.4.3)? How do I show that the offsets are having some effect, or are being set at all?