Cannot change to Beer Profile

I am unable to change from beer constant, or from fridge constant to beer profile.
I can click ‘new’, and name it. I can put in the times and temperatures, and click ‘save’. I then close the window, but the new profile name doesn’t appear. Despite this, I click ‘apply’. Nothing happens for a few seconds, and then brewpi reverts to its previous state, for example beer constant or fridge constant.
This is very frustrating. I’ve tried rebooting the pi, halting it with sudo halt -p and switching off the arduino too, and then restarting the whole lot. Still no joy.

A while back, I deleted all profiles and beers as per instructions by Elco, and I wonder if I deleted some sort of initialising profile template, if there is such a thing. Could this be something to do with it?

Can you give the output of git status in the web directory?

pi@bb /var/www $ git status

On branch legacy

Changes not staged for commit:

(use “git add/rm …” to update what will be committed)

(use “git checkout – …” to discard changes in working directory)

deleted: data/Sample Data/Sample Data-2012-09-26.json

deleted: data/Sample Data/Sample Data.csv

deleted: data/profiles/Sample Profile.csv

no changes added to commit (use “git add” and/or “git commit -a”)

Sorry for the formatting! I didn’t preview

You can edit messages.

Try running git reset --hard

I ran git reset --hard, and now receive Error Saving Profile!
This is progress but is there a file permissions issue here?

Try running /home/brewpi/utils/ to find out :slight_smile:

Brilliant! That fixed it. It saved the profile and is now running.

Thank you very much. I know we all appreciate your hard work on this project, and I’ve been following it since it beginnings. I think it’s superb!