Cannot read LCD text from python script / script not running

I have been through the forum posts and the old forum, none of the apparently similar problem solutions have worked.

I decided to update the software on my RPi B and BrewPi Arduino (Uno Rev C?).

All goes smoothly until when the web GUI is running I get the message “Cannot read LCD text from python script” and nothing I have tried will restart the script.

Among previous solutions I have tried:

python /home/brewpi/ --kill

“Errors while opening serial port: could not find compatible serial devices”

python /home/brewpi/ --status

“No BrewPi scripts running”

The BrewPi physical LCD display indicates the last script it had when connected to the fridge. I have also played around with the cable linking BrewPi & RPi and that does not appear to be a problem.

Anyone encountered and solved a similar problem?

Thanks in advance


Please post the output of:

python /home/brewpi/

If your Arduino is listed, but not in compatible ports, that might be a bug.


port = /dev/ttyACM0

To config.cfg to disable automatic detection.


Please post the output of:

python /home/brewpi/
If your Arduino is listed, but not in compatible ports, that might be a bug.

Python cannot open file ‘/home/brewp/’ [Errno2] No such file or directory

port = /dev/ttyACM0
To config.cfg to disable automatic detection.

Where will i find this file?. The only directory is brewpi-tools, with



You made a typo.

Navigate to /home/brewpi

Config.cfg should be placed in the settings dir

Hi, sorry to chime in here but i am having a similar issue.

After running “” i get the following:

pi@raspberrypi ~ $ python /home/brewpi/
All ports:  ()
Compatible ports:  ()
Selected port:  (None, None)

Any idea? I did fry an arduino in a previous setup when i got some longer sensors (wired one up incorrectly) and i have since replaced the arduino/sensors.

Can you try again with sudo? Do you see any devices with:

ls /dev/ttyACM* or ls /dev/ttyUSB* ?

There was no devices reading so I ended up replacing the Arduino & Pi and it looks like the Arduino board was stuffed so i’ll just use my other Pi for another little project i have in mind.

I just had a whole pile of problems with setting up the wifi after formatting my SD card and reinstalling everything. I finally got it sorted today, and just managed to get BrewPi installed super simply. Thanks a bunch. Lets hope my relays work now, otherwise i’ll be waiting a couple of days while new ones turn up haha

All good, i need to make a starter for the next beer anyway!
Thanks Elco & all above for the posts. Its helped me understand a lot more about the way to work in Terminal/SSH

Just to give an update, uninstalling the heating and cooling devices cleared the device itself and when i reapplied the changes it all clicked on like it should. So pumped to have it back up and running, i also have enough spares to build a second one. Might be able to control my serving fridge a little better and hook up a tower cooling system or something.

thanks again!