Cannot see Block Relations

My story:

It’s been a while since I had used Brewpi for lagering. I recently revived my system (finally got my Picobrew Z) and found that my original Spark would not open a DFU connection and I had no way to update it after I managed to wipe it (wasn’t paying close enough attention) and it was on a very old firmware version.

Rather than fight that I bought a SparkV3 and built a new Brewpi Pi and everything worked well over USB. However, the Spark would get an IP and soon after would stop responding to traffic. It has a static address with 72 hour lease (which it never ran long enough to test) and after trying everything I could to get it to work, put in a new topic with the problem…

Alas my impatience resulted in a belief that since BrewBlox was now on the scene that there was less enthusiasm to work on it, as I never received a response on this issue.

So I built a BrewBlox instance, flashed the SparkV3 with the BrewBlox firmware and setup WiFI Onto the next set of issues…

When I brought it up initially, it simply would not show anything at all when trying to setup a fermentation arrangement. In addition it was dropping WiFi and occasionally rebooted randomly. I then changed the docker-compose.yml to discovery=usb and was able to now see the sensors and actuators. However, trying to learn more and get more in-tune with BrewBlox I was following Fermentation Arrangement Guide and went to the Spark service and to the menu to show the block relations and the screen does not show anything (blank).

I’m hesitant to continue until I start seeing things correctly. I’ve attached the log snapshot I have taken at this point.

Please advise…I’d love to get my picobrew Z going and start lagering but so far this has taken a lot more time than I expected!
brewblox-blocks-spark-one.json (4.6 KB)

According to your logs, everything seems to be in order.

What browser are you using? IE/Edge have problems rendering the SVG elements we use for block relations.

As a side note: the BrewPi software is indeed discontinued, and will not receive further updates. My apologies for the lack of response to the earlier post.

Good call, not using Edge or IE. Using Firefox which was not showing, probably in my settings somewhere (hmmm). I fired up Chrome and it shows the page.

Thank you for the quick response.

That’s a bug, not an issue with your settings. I added an issue for it, and we should have it fixed soon.

Good to know. I looked through the extensions and settings and could not find anything that would have caused the result.