Can't change temp mode from Web UI

Running a Pi/arduino combo. Software is up to date. Devices are install and such. However it won’t let me change the temp mode from the web UI. I have to go into the maintenance panel and select the temp mode under advanced setting to change the mode. If I try to change it in the web UI it automatically reverts to what is set in the maintenance panel.

I have an older install on a different unit that doesn’t perform this way.

Is this normal behavior for the updated software?

Did you check out the legacy branch?
Arduino users should install/update to that branch by running:

sudo ~/brewpi-tools/ --ask

Try the ‘reset factory defaults’ button on the bottom of advanced settings.

I’m on legacy and I did try the reset button.

I did reinstall the legcy version after I had initially installed the regular version. Maybe that is the problem. I think I’ll wipe the pi and uno and start fresh.


Also when trying to switch between modes it seems switching to beer constant mode is the one that’s really broken.

Here’s what works and what doesn’t

Beer profile to fridge cont : yes
BP to BC : no
BP to Off: yes
Off to FC: no
anything to BC: no

I think it must be software related as you can send it to the Arduino fine from the maint panel

I tried this and I could not reproduce the problem.
Do you have a warning in the log that reads something like:

Jan 03 2016 12:11:06   Fridge temperature setting 68.0 is outside of allowed range 1.0 - 60.0. These limits can be changed in advanced settings.

I think it must be related to that. Check your min/max temperature settings (only on Arduino).

That was it Elco. Didn’t realize my temp was set too low. Thanks.

One other question. I no longer see the ability to set the min or maximum temp in the advanced setting like in older versions? Is this somewhere else or has it been removed?

You are probably not running the legacy branch for the web interface then. It is still there for Arduino, just check out the right branch.