Can't program Arduino during setup

Hello all

This is my second brew pi. First one was earlier this year and the install went off without a hitch. I used the exact same parts for this one but can’t get it working.

When trying to program the arduino with the most recent firmware I get the ol

" Warning: Cannot receive version number from controller. Your controller is either not programmed or running a very old version of BrewPi. Please upload a new version of BrewPi to your controller."


I’ve tried clearing the epromm as suggested on other threads but it’s not working and read through some of the other threads but can’t get it working. Any other suggestions?

Is there anyway to pull the hex file off my other arduino? Could try that.


Well after a lot of tinkering I got it working.

  1. Ran across a thread about legacy software. So I reverted to the legacy build because the new software won’t work with an arduino i guess
  2. Still couldn’t load the firmware to the arduino. So I tried loading it manually with hexload. It loaded it but still wasn’t working. But it now did allow me to read and re-write firmware onto the arduino. After this it worked and I was able to configure my probes ect… so problem solved.

If you ever need it here is a link to the older code on Github:


Cheers @jwalkermed This worked for me also. i used xloader with the uno plugged into my pc, and installed the .hex file via that, and then plugged it back into the pi and it worked a charm.