Can't reprogram controller


I have updated to 0.5.0 and things were running well, except for the Spark rebooting spontaneously from time to time. I figured it might be due to the beta release. So im trying to up date to the latest release, but I can’t reprogram the controller. I get the following error:

The update script can automatically check your controller firmware version and program it with the latest release on GitHub, would you like to do this now? [Y/n]:y
Stopping any running instances of BrewPi to check/update controller…
Traceback (most recent call last):
File “/home/brewpi/utils/”, line 268, in
result = updateFromGitHub(userInput=userInput, beta=beta, useDfu=useDfu)
File “/home/brewpi/utils/”, line 48, in updateFromGitHub
File “/home/brewpi/utils/”, line 35, in quitBrewPi
allProcesses.stopAll(webPath + “/do_not_run_brewpi”)
File “/home/brewpi/utils/…/”, line 247, in stopAll
dontrunfile = open(dontRunFilePath, “w”)
IOError: [Errno 2] No such file or directory: ‘/var/www/html/do_not_run_brewpi’

*** Done updating BrewPi! ***

Does anyone know what I’m doing wrong?

Do you have your web files in /var/www or /var/www/html?

I think I might have caused that by changing the default to /var/www/html/ now.

If you have your files in /var/www, can you add this to config.cfg?
wwwPath = /var/www

My files are in var/www. I tried adding it to the config file, but it still wont Update.

Jul 23 2017 19:57:28 Opening serial port
Jul 23 2017 19:57:38 Errors while opening serial port:
Could not find compatible serial devices

Unable to receive version from controller.
Is your controller unresponsive and do you wish to try restoring your firmware? [y/N]:
Could not find compatible device in available serial ports.
Firmware update done

*** Done updating BrewPi! ***

Please refresh your browser with ctrl-F5 to make sure it is not showing an old cached version.

Do I need a USB connection to Update?

Ok, sounds like that fixed the first error, but we ran into another.

Updating over WiFi was added in 0.5.1. If you are running a lower version, you need to update over USB one more time.

I just removed defaulting to use USB (DFU) when running as root and tested a WiFi update 0.5.1->0.5.2

Looks like the controller Got updated, but I still can’t access raspberrypi.local. And if I run the updater again it wont Update over wifi.

To be able to access a .local address, your PC should have the bonjour service installed. It comes with iTunes, but can also be installed separately.

On the pi, you will have to install avahi-daemon. It is installed by default on HypriotOS, if you choose to install with our new docker based install process.

I cannot comment on the wifi update failing. I don’t know if you have a successful wifi connection to begin with and which versions you are running.

I had everthing working with the beta software. Access to .local and the spark running via wifi.
I do not have a pc, I use an ipad and SSH.
Should I get a pc from work and do a reinstall?

Can’t really answer that, because I cannot pinpoint the problem.

  • Do you know if the pi has a successful network connection?
  • Do you see both the pi and spark with the app Fing?

I recommend docker for new installs, but you can do a full re-install the old-fashioned way by running the install script again too. You can do that from ssh with your ipad.

The pi is connected through a cable, and I have no problem accessing it via SSH.
Both the pi and the spark show up in Fing

are you typing: http://raspberrypi.local ?
If you type in the IP address instead, do you see the web interface?

Did you edit config.cfg with the IP address of the Spark and did you check that the address didn’t change?

To help you debug:
The script reads config.cfg for the port to connect to. To use wifi, this is set to socket:://:6666

You should make sure the script is up-to-data to be able to connect and flash via wifi.

I have reinstalled the pi using docker, and now i have a working connection to the pi webinterface.
Now I just need to setup the wifi connection between pi and spark.
I don’t know how to edit the .cfg file without gui, and startx is not working in the New setup.
Is there a command to edit the cfg?

In portainer (<raspberry ip address>:9000), go to the brewpi container, then click on console and connect.

You will be dropped into the bash shell of the container.
Then you can run:

cd /home/brewpi/settings
cp config.txt.example
nano config.cfg