Can't start new brew


Can you please answer all questions?
A failed upgrade could mean the script is not running, which could explain your other problems.

If you want to do a clean reinstall, I recommend the docker approach as described on our wiki.


Sorry, I am a very basic user here, I followed the guides when I first set this up months ago, other than that I am not really close to this so unable to know even how to check what you have asked (pasted again below). Not looking to take up lots of anyones time here, only looking to understand what has happened since updating and how I can resolve with some help of course.

Is your web interface installed in /var/www/html?
Is the brewpi script installed in /home/brewpi?

What’s in /home/brewpi/settings/config.cfg?


Did you intend to type the answers below the questions?
I am trying to understand what happened too, but I do not have enough information, which is why I am asking specific questions.


Sorry what I mean to say is I am not sure how I can check what you are asking? My knowledge on this stuff is next to none. What command in Terminal or anywhere else do I need to do to check the above to allow me to display it here?

Appreciate you taking the time to have a look.

I can see the directories are there but not sure how to get the contents. I did have this returned on the config one. Again apologies if vague.

/home/brewpi/settings/config.cfg: line 1: beerName: command not found
/home/brewpi/settings/config.cfg: line 2: dataLogging: command not found
/home/brewpi/settings/config.cfg: line 3: profileName: command not found


Not sure if this helps at all? I tried the docker method but couldn’t get the wifi connection working so installed cleanly on Raspbian as I did before, still the exact same issue.

pi@raspberrypi:~ $ ls /home/brewpi brewpiVersion.pyc LogMessages.h parseEnum.pyc tests
autoSerial.pyc brewpiJson.pyc BrewPiSocket.pyc logs settings utils data pinList.pyc start.bat
backgroundserial.pyc BrewPiProcess.pyc BrewPiUtil.pyc MigrateSettings.pyc
brewpi_dontrun expandLogMessage.pyc programController.pyc temperatureProfile.pyc

pi@raspberrypi:~ $ ls /var/www/html
beer-panel.php control-panel.php font getLogs.php program_arduino.php start_script.php uploads
brewpi_logo.png css get_beer_data.php index.php save_beer_profile.php touch-icon-ipad.png utils
config.php data get_beer_files.php js socketmessage.php touch-icon-ipad-retina.png
configuration.php defaultSettings.json get_beer_profile.php maintenance-panel.php socket_open.php touch-icon-iphone.png
config_user.php.example favicon.ico get_beer_profiles.php previous_beers.php sockettest.php touch-icon-iphone-retina.png

pi@raspberrypi:~ $ ls /home/brewpi/settings/config.cfg


What do you have inside config.cfg?
cat /home/brewpi/settings/config.cfg

And does your Spark display an IP address?


Hi - I tried the docker method again this morning and got it successfully working. It seems for the wifi that the " characters input using notepad did not display as such in the Pi itself, I amended there and all good now.

Thanks for taking the time to come back to me on this.


Awesome. Maybe we should instruct to use nano in the container itself to edit the file instead.


It may just be because I am using a Mac where " and @ are mapped different compared to most other keyboard layouts so likely just a small issue. It was only apparent in nano as looked fine in the text file. All good now though.