Can't start new brew


Hi all,

Just got my beer in and wanted to start a new brew scheme in the GUI.

However, when I select “+ new Brew” and give it a name and press “start new brew”, I get a notification window that has no message and the brew won’t start.

It also says script not running.

I ran the update script today on the software of my 2015 brewpi Spark. I am afraid there is a software version mismatch with my hardware?



It also says: Couldn’t write to socket: [111] Connection refused Is the script running?


If the script is not running you cannot start a new beer.
Check the logs to see why. Maybe you need to run the fix script.

If you are running on an Arduino, make sure you have checked out the legacy branch for both the web UI and the script.


Quick response, thanks!

I reinstalled and a “sudo -u brewpi python /home/brewpi/”

That worked!

Thanks you,


Still not 100% though. After I start a new brew, it says I need to reload the page. But it stays at the old brew.

At least the script is running and I can set the temperatures, so the beer is safe for now.



Sounds like a permissions issue. Or maybe in config.cfg the wwwPath is incorrect.

You can also try the docker install procedure as described in the wiki.


“If you are running on an Arduino, make sure you have checked out the legacy branch for both the web UI and the script.”

I run a BrewPi Spark 2015 edition :slight_smile:


I wasn’t implying that you did, just guessing possible causes :slight_smile: Thanks for supporting us.

Maybe following the docker install method is the easiest way forward. That’s going to be the official install procedure from now on. Makes it easy to reinstall while keeping data and is quicker to set up.


Yes I will try and report back here, I probably missed something during installation.


Hi @Ruudt,

make sure your /var/www/html/data and /home/brewpi/ belongs to the brewpi user that is running the script.
Beware also, if you started it as root before, you might have created new files belonging to root and no more accessible to the daemon that is restarted using the brewpi user. If that’s the case, change the owner from root to brewpi to these data files.

Also check your log messages around the socket error message, it most of the time says what cannot be opened for reading or writing.




I am also having this issue when trying to update a profile and a new log. I get the below message

“I/O Error(2) updating profile: No such file or directory”

I am not well versed in all this, is there something I can do in Terminal to fix this?


Did you delete /var/www/html/data/profiles?


I tried the below with no joy. I am not very clued up on all this being reliant on the step by step to get this up and running. Since upgrading the version this seems to be causing these issues.

pi@rhodesy ~ $ sudo rm -R /var/www/html/data/profiles
rm: cannot remove `/var/www/html/data/profiles’: No such file or directory


I reinstalled but still getting these errors…


Could you give us the output of:

  • ls -l /var/www/html/data
  • ls -l /home/brewpi/data



Sure, output below. Nelson is the profile I just created and tried to start logging however it is stuck on sample. I also cannot apply it as I get ‘I/O Error(2) updating profile: No such file or directory’

pi@rhodesy ~ $ ls -l /var/www/html/data
total 4
drwxrwxr-x 2 brewpi www-data 4096 Aug 24 19:42 Nelson
pi@rhodesy ~ $ ls -l /home/brewpi/data
total 12
drwxrwxr-x 2 brewpi brewpi 4096 Aug 24 19:39 My First BrewPi Run
drwxrwxr-x 2 brewpi brewpi 4096 Aug 24 19:41 Nelson
drwxrwsr-x 2 brewpi brewpi 4096 Aug 24 19:38 Sample Data


This removes the profiles directory. The point was to actually have one, so I intended to ask whether you removed it (which you shouldn’t do).

Try this:

mkdir /var/www/html/profiles
sudo bash /home/brewpi/utils/


Sorry for the confusion. I did not delete the directory until my post above. So still facing the issue both before I deleted and again since reinstalling. I tried the commands above but still getting the exact same issue where I cannot log a new brew nor can I load any profiles.

Appreciate the assistance and bearing with me on this.


Which method did you use to install? On which system? Is the script running?

Is your web interface installed in /var/www/html?
Is the brewpi script installed in /home/brewpi?

What’s in /home/brewpi/settings/config.cfg?


I am running this on a raspberry pi 2/Spark 2 which was working fine since I set it up. I then updated the firmware where I now am facing all the issues. I have not amended any installations or the likes other than posted above with nothing touched at all before posting.

Whats the easiest for me to cleanly uninstall and reinstall using Terminal?