Cert issue during new install of Brewblox

I seem to be getting a certificate issue when installing Brewblox software. This happens on a new install of the software on a Pi3b+ with a new SD card and fresh install of the OS.

Setup completes without any issues but I am not able to reach the Web UI using the ```
brewblox-ctl up command.

I’ve tried three times now with a fresh format of the SD card between tries and can repro this same error.

Your help is very much appreciated!

Pi 3B+
New SD card
Raspbian lite 32bit
Spark v1

Firmware and software are up to date - brewblox-ctl update used to check
Logs: https://termbin.com/xpkr

The issue seems to be with Traefik -
Attaching to brewblox_traefik_1
traefik_1 | 2020-06-30T19:26:56.150165996Z time=“2020-06-30T19:26:56Z” level=error msg=“failed to load X509 key pair: tls: failed to find any PEM data in certificate input”
traefik_1 | 2020-06-30T19:26:56.150937993Z time=“2020-06-30T19:26:56Z” level=error msg=“Unable to add a certificate to the entryPoint “https” : unable to generate TLS certificate : tls: failed to find any PEM data in certificate input”

It sounds like the generated cert is having issues.
You can check them by running:

(Do not post the output!)

cat traefik/brewblox.crt
sudo cat traefik/brewblox.key

The crt file should start with


and end with


The same for the brewblox.key file, but then with “PRIVATE KEY” instead of “CERTIFICATE”.
The middle for both files should be a square block of gibberish.

Thanks for the quick reply. I have re done the install on another pi and all has gone through now. Thanks again and looking forward to playing with this new code.

1 Like